Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I would like to submit a paper to an Elsevier journal, which uses elsarticle document class. elsarticle loads natbib but I've been using biblatex instead of BibTeX throughout most of my files (I have a common .bib file for all my publications which is biblatex compatible right now). The problem is that I have many authors with special characters (like ø, å, ü etc) and BibTeX was giving errors when compiling because of the encoding - this was the reason why I switched to biblatex in the first place.

Is there a quick way to make my .bib file compatible with BibTeX without manually substituting those special characters with their TeX versions?

Or will Elsevier become biblatex compatible soon?

share|improve this question
Do you know the website thecostofknowledge.com ? Besides, after acceptance your tex file is going to be retypeset by the copy editor using their own internal style. So you don't need to be 100% accurate about the style file and other stuff. There is no need because it's there for your own convenience. –  percusse Apr 24 '13 at 15:54
Ok. So I could edit elsarticle.cls myself and make it biblatex compatible? –  remus Apr 24 '13 at 15:57
As you wish but they will ask for a proper .bib file with \"{u} and whatnot afterwards if the entries are not displayed properly. And yes, they do that. They do other terrible things to your images etc. so you are bound to their archaic workflow not the other way around. –  percusse Apr 24 '13 at 15:59
@percusse and Remus, this might be of help: tex.stackexchange.com/questions/109069/… –  Mario S. E. Apr 24 '13 at 16:06
biber has an option like --output_safechars, which will encode UTF-8 characters into LaTeX-style macros, thus providing you with an ASCII .bbl file. But that is not the same as using BibTeX, which is what I suspect the journal wants/requires. However, I think I vaguely remember some question on this site about getting from .bbl to .bib --- but I could be wrong! –  jon Apr 24 '13 at 16:52

3 Answers 3

up vote 12 down vote accepted

biber will do such a conversion of the text encoding for you in tool mode via

biber --tool --output_encoding=ascii --output_safechars file.bib

If file.bib is

  author =   {Beauville, A.},
  title =    {Variétés Kähleriennes dont la première classe de
                  Chern est nulle},
  journal =  {J.~Differential Geom.},
  year =     1983,
  volume =   18,
  pages =    {755--782},

then the converted file looks like

  author = {Beauville, A.},
  title = {Vari\'{e}t\'{e}s K\"{a}hleriennes dont la premi\`{e}re classe de Chern est nulle},
  journal = {J.~Differential Geom.},
  year = {1983},
  volume = {18},
  pages = {755--782},
share|improve this answer
One thing to note - if the input encoding is not ascii (default is utf8) and the output encoding is ascii, safechars is automatically set. –  PLK Apr 26 '13 at 14:00

One can convert a .bib file that contains special characters (e.g. umlauts) to a .bib file with safe chars (i.e. TeX equivalents for those special characters) using bibutils:

bib2xml -i unicode mydb.bib > mydb.xml
xml2bib mydb.xml > mydb_bibtex.bib

mydb_bibtex.bib will not throw any encoding errors when compiled with bibtex.

share|improve this answer

From my recent success of a journal submission to Elsevier, I feel it's easier if you put everything (except the figures) into one single tex file and upload as "manuscript".

To integrate the bibliography into .tex file is actually easy, you just compile your original .tex with the .bib file as you normally do. You will find a .bbl file is generated (along with other compiled files, .pdf, .aux, .log, etc.). Then you comment out the \bibliography{...} line in your .tex file and copy all the contents in the .bbl file right after the line.

share|improve this answer
Thank you for sharing your experience –  Henri Menke Jul 29 '13 at 20:49
You could just upload the .bbl file and leave the .tex file intact. It worked for me. –  remus Nov 4 '13 at 11:10

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.