Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

This question already has an answer here:

Whenever I type something such as The energy's source, TexShop changes the apostrophe into a curly one which does not print in the PDF.

How can I stop future apostrophes from being changed without much of a hassle ?

Using TexShop :

\documentclass[12pt,a4paper]{report}
\usepackage[lmargin=3.81cm,tmargin=2.54cm,rmargin=2.54cm,bmargin=2.52cm]{geometry}
\linespread{1.5}
\usepackage{mathptmx} 

\begin{document}

it's

\end{document}

This is what happens :

I type an apostrophe, the TexShop changes it to a curly apostrophe in the editor :

enter image description here

However this does not print in the PDF file as TexShop doesn't recognise it when it TypeSets.

If I manually change it to

enter image description here

Then it prints normally, but I can't keep changing it manually every time I type apostrophes because (1) I forget (2) it's not convenient.

share|improve this question

marked as duplicate by Herbert, Marco Daniel, Guido, Thorsten, Claudio Fiandrino Jun 5 '13 at 6:14

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Please add a minimal working example (MWE) that illustrates your problem. It will be much easier for us to reproduce your situation and find out what the issue is when we see compilable code, starting with \documentclass{...} and ending with \end{document}. –  Papiro Apr 25 '13 at 22:09
    
What editor do you use? I don't have that problem in TeXmaker on Mac OS... –  Jubobs Apr 25 '13 at 22:09
    
A workaround is to use \usepackage[utf8]{inputenc} to handle "smart quotes" in LaTeX. –  Guido Apr 25 '13 at 22:12
    
@Jubobs I tagged TexShop –  Razor Apr 25 '13 at 22:12
1  
Take a look in your system prefs under Language & Text. There you can change the automatic conversion of quotes. –  Bart Arondson Apr 25 '13 at 22:47

1 Answer 1

up vote 1 down vote accepted

Apparently using TexShop I should disable this :

Edit > Substitutions > Smart Quotes

The editor doesn't change apostrophes to curly ones anymore.

share|improve this answer
    
@Papiro Thank you for answering though. I was planning to add it is a macro and insert it as a shortcut whenever I type ' if I couldn't figure it out. –  Razor Apr 25 '13 at 22:59

Not the answer you're looking for? Browse other questions tagged or ask your own question.