TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So, I was in a hurry, and didn't read the copious verbiage on TeX Live as directed by the TeX Live Utility when you have an out-of-date TeX Live install (I had 2010).

So, I'm comfortable with the command line and figured I'd be OK following the directions next to the bolded text: How to acquire TeX Live (using install-tl).

That installed something I could use from the command line, but none of the Mac stuff could find it (system panel, TeX Live Utility, ...). Changing the location of my TeX Live distribution in the preferences resulted in a very limited file selection dialog. I tried dragging the /usr/local/texlive/.../bin for TeX Live 2012 into this dialog, and it let me do that. But, it still seems to think I'm at 2010.

So, I looked around and found the MacTeX Additions package, which seemed to expect an installed TeX Live, and would do the rest. This resulted in no change.

Then, I downloaded and installed the full MacTeX 2012 package. Now, TeX Live 2012 shows up in my preferences pane, but TeX Live utility is still borked.

So

  1. can we please change the documentation so this doesn't happen so much? It seems like people go the install-tl route on OSX with some frequency based on the questions on this site!

  2. I am afraid I have no idea how to update my TeX Live Utility so it'll work correctly. Any pointers? I suspect if I just delete the preferences for it, that'd work. I don't think that deleting it and reinstalling will work, as I tried that too!

share|improve this question

Rather than installing a new version of TeXLive, a better solution might be to install the latest version of MacTex, which contains a stable version of TeXLive and Tex Live Utility. I'm downloading that now...If I don't post that this was successful in a day or so, shoot me a reminder!

Others may find this helpful: Tex Distribution Pane not working after installing BasicTex2013. I also elaborated there some of my own difficulties....

share|improve this answer
    
Downloading/installing the latest version of MacTeX (as opposed to TeXLive) worked for me! – jvriesem May 1 '14 at 18:23

This is an old question, so note that I've tried to answer it in some detail at Reconfiguring Tex Live Utility for 2014.

In short, the OP's solution of "I tried dragging the /usr/local/texlive/.../bin" should have worked, assuming the … was an actual path…but I'd need more details to know what happened. Since it started working after installing MacTeX and re-pointing the TeX Distribution preference pane, I suspect the edit was never committed.

In answer to the second part of the question, the proper way to read TLU's preferences is by executing defaults read com.googlecode.mactlmgr.tlu in Terminal; see man defaults for information on modifying or deleting preferences, if you really think you need to do this (you don't).

share|improve this answer
    
The ... was an actual path! But at this point, I have no ability to recreate the details. Thanks for updating the instructions, though! – Dav Clark Sep 7 '14 at 18:25
    
@DavClark, well, you definitely had the right idea, then! I've added notes to TLU's Help book to clarify how to do this. If I get a chance, I'll test this again to make sure it still works. – Adam Maxwell Sep 8 '14 at 1:02
    
I have the same problem as the OP - for a legitimate reason, which is that I was on a very slow connection and MacTeX was predicting about 3 times the download time as TL vanilla, which I didn't have. Anyway, I cannot drag anything into the preference pane (from MT 2012). And short of recreating the pane (and I can't even figure out how to do that in Xcode!) I can't find a way to use Terminal to edit the pane to include this. grep -r 2012 /Library/PreferencePanes/TeXDistPrefPane.prefPane/Contents/ returned nothing! (I'll also comment on the other post as well.) – kcrisman Dec 5 '14 at 20:48
    
@kcrisman The question I was answering was in regards to TeX Live Utility's preferences. This is entirely separate from the TeX Distribution system preference pane (which indeed does not support drag-and-drop). – Adam Maxwell Dec 6 '14 at 0:21
1  
@kcrisman I have been working on a way to do this, but it's not trivial. The TeX Distribution prefpane is broken on Yosemite, also. – Adam Maxwell Dec 6 '14 at 22:44
up vote 1 down vote accepted

This actually wasn't that hard (just non-obvious). I was trying to select one of the texdists from /Library/TeX/Distributions (makes sense to me!), but the correct path is /Library/TeX/texbin. Then, you can switch the TeX distro using the System Panel, and TeX Live Utility will work properly.

I still have no idea where TeX Live Utility settings are stored!

share|improve this answer
1  
I think they are stored in the files locates in /Applications/TeX/TeX\ Live\ Utility.app/Contents/Resources/ – Namrod Apr 27 '13 at 20:14
    
Why does this preference then persist when I move the old TeX Live Utility to another location and re-install? – Dav Clark Apr 28 '13 at 18:10
    
@Namrod, TeX Live Utility doesn't store preferences in its bundle. They are stored in Apple's standard location for user-domain, which is presently ~/Library/Preferences. Note that the on-disk state is no longer guaranteed to be synchronized with what the application sees, as of 10.7 or so. – Adam Maxwell Sep 4 '14 at 18:16

I encountered this problem after (being forced to) an update to MacTeX 2016. I had never met it before, so it took some time to reach the (quite obvious) solution of setting the path in Preferences -> TeX programs.

However, I could only choose /usr/local/texlive/2016/bin/x86_64-darwin, so the problem will reappear next year, when this solution is long forgotten. For a (more) permanent solution I followed Maxwell's hint, and ran the following command in a terminal window:

defaults write com.googlecode.mactlmgr.tlu TLMTexBinPathPreferenceKey '/usr/local/texlive/current/bin/x86_64-darwin’

For some reason the 'current' in this path had been replaced by '2015', causing the problem.

share|improve this answer
    
IF YOU INSTALL MACTEX, PLEASE DO NOT DO THIS, OR YOU WILL BE RESETTING IT EVERY YEAR! The correct path is /Library/TeX/texbin for MacTeX 2015 and later. Read TeX Live Utility's Help on this topic for more details. – Adam Maxwell Jul 19 at 4:55
    
Adams advice certainly works. Note that, depending on local settings, you may have problem finding the Library directory in the preference pane, since it is one of the directories given a local name in the graphical interface (for me it is named Bibliotek). – Kåre Olaussen Jul 20 at 7:41
    
Adam is the sole author and maintainer of TeX Live Utility, so he's reliable on this topic, if nothing else :). Thanks for the comment on localized names; I'll try to add a note on that in the help! – Adam Maxwell Jul 20 at 14:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.