Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am having issues with -shell-escape. I do not know really what this is, and how to apply it. Furthermore, I have read elsewhere that I is possibly dangerous to summon this command. Any help would be hugely appreciated.

In order to incorporate a simplified numbering system for compounds in my document, I am trying to replace a TMP marker within a chemdraw .eps file. However, when I include

\usepackage[runs=2]{auto-pst-pdf}

I get this message:

enter image description here

If I remove the above command then the typset completes, but the TMP markers in the graphic remain TMP1, TMP2 etc.

This is my input:

\begin{scheme}[ht]
\schemeref[TMP1]{\CNlabel{MT004}}
\schemeref[TMP2]{\CNlabel{MT002}}
\schemeref[TMP3]{\CNlabel{MT005}}
\schemeref[TMP4]{\CNlabel{MT006}}
\schemeref[TMP5]{\CNlabel{MT007}}
\schemeref[TMP6]{\CNlabel{MT009}}
\includegraphics[width=0.65\textwidth]{RS001.eps}
\caption{Macrocycle synthesis}
\end{scheme}

The tutorial I am following is detailed here: http://www.jkwchui.com/2010/03/writing-chemistry-with-latex-33/

I am using TeXShop for Mac.

share|improve this question
1  
on the command line it means literally adding the option --shell-escape It is probably a configuration option in texshop but I can not help with that. It is needed to allow tex to call out to the operating system to (for example) convert eps to pdf. as any command that can call to the operating system it could in theory be misused to run commands that you don't want running, but the standard auto-pst package does nothing bad:-) –  David Carlisle Apr 27 '13 at 11:23
    
I am sorry, where in the command line do you mean? –  Alastair Apr 27 '13 at 11:27
1  
If you are running latex "by hand" you would do pdflatex --shell-escape myfile.tex instead of pdflatex myfile.tex You just need to tell texshop to do that... –  David Carlisle Apr 27 '13 at 11:29
    
@Alastair see Command-line interface –  cgnieder Apr 27 '13 at 11:29
    
You might be best running in 'traditional' latex+dvips+ps2pdf mode if you are having trouble: the 'magic' that replaces TMPX with a number can only be done with .eps files. –  Joseph Wright Apr 27 '13 at 17:08

1 Answer 1

To enable shell escape in TeXShop:

enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.