Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

It seems that each time I try to update/install new packages, the MiKTeX update wizard will internally first connect to http://api.miktex.org/Repository.asmx.

Is it possible to skip this step? It's really slow for me to connect internationally but would be much much faster since lots of mirrors within country are available.

Or is there any trick to use proxy only for this http://api.miktex.org/Repository.asmx URL but not mirrors I will connect to?

share|improve this question
3  
I can't see this behaviour. miktex connects to this ip only if I use the option "use the nearest repository" in the update manager. But you can always download the packages from a CTAN mirror with some other means in a folder and then use this folder as local repository for updates and installations. This will need no online connection at all. –  Ulrike Fischer Apr 28 '13 at 10:15
    
Welcome to TeX.sx! –  texenthusiast Apr 28 '13 at 16:38
add comment

closed as off topic by Speravir, Guido, Thorsten, Kurt, Harish Kumar May 2 '13 at 0:56

Questions on TeX - LaTeX Stack Exchange are expected to relate to TeX, LaTeX or related typesetting systems within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

up vote 3 down vote accepted

Third version in reaction to comment (actually off-topic for TeX.SX in my opinion):

For selective connection settings you can install a local proxy server. I never needed one, so I cannot say anything about these, but well-known, renowned examples are Squid and Proxomitron (if you are by any chance German: Der Proxomitron - Deutsche Distribution).


Second version:

I would actually recommend not to change anything, but I see only one way without any guarantee that it works, in fact there is a high chance, that this breaks the whole update process (edit: yes, confirmed by wlnirvana in comment below):

  • Go to C:\Windows\System32\drivers\etc\. Make sure you have there writing rights.
  • Make a safe copy of file hosts.
  • Open this file with a text editor and add this line to the end:

    127.0.0.1    api.miktex.org
    

    Starting with # you can add a comment for explanation.

  • Save the file.

Then, every request to api.miktex.org goes to your local host, i.e. your computer, instead.


First wrong version, just written for expression of what was written in comment:

What Ulrike wrote – do not choose the option “Use the nearest package repository.”, but one of the two other options in update dialogue, and MiKTeX will directly connect to the chosen mirror:

MiKTeX update dialogue window with options highlighted

share|improve this answer
    
I do use the two options you mentioned above, however I think it probably still connects to that URL first because I see it when I use GoAgent to get international internet access... –  wlnirvana Apr 29 '13 at 1:54
    
@wlnirvana: I used tcpview from the sysinternal suite and couldn't see any connection (beside the connection to the repository itself) if I use a fix repository. –  Ulrike Fischer Apr 29 '13 at 7:37
    
@UlrikeFischer After using of Wireshark I must unfortunately confirm wlnirvana’s observation. I yesterday just wanted to express, what you’ve written in your comment (hence set in community wiki), and didn’t test myself (first had to install Wireshark). –  Speravir Apr 29 '13 at 20:35
    
@Speravir Is there any way to use a proxy, say 127.0.0.1:9999, only for this URL while others are not affected? –  wlnirvana Apr 30 '13 at 5:26
    
@Speravir Unfortunately modifying hosts doesn't help solving this problem. Maybe Miktex connects to the server to do some verification stuff :( –  wlnirvana Apr 30 '13 at 12:13
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.