Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm trying to make the code of the following post work: How to make a bib entry appear also in the main document but I get some thing that I don't expect:

enter image description here

I'm using the default TeXShop command: pdflatex --file-line-error --synctex=1. I also tried to run bibtex, but I get the following message:

This is BibTeX, Version 0.99d (TeX Live 2012)
The top-level auxiliary file: test.aux
I found no \citation commands---while reading file test.aux
I found no \bibdata command---while reading file test.aux
I found no \bibstyle command---while reading file test.aux
(There were 3 error messages)

EDIT

This is the code:

\documentclass[12pt]{article}
\usepackage[utf8]{inputenc}

\usepackage{filecontents}
\begin{filecontents}{\jobname.bib}
@book{auth1:2000,
title = {A book},
author = {A. Thor},
date = {2000},
publisher = {Some Company},
location = {A City}
}
\end{filecontents}

\usepackage[backend=biber,]{biblatex}
\bibliography{\jobname.bib}

\begin{document}

\fullcite{auth1:2000}
\cite{auth1:2000}

\printbibliography
\end{document} 

which is clearly wrong as I'm citing in the test. What's wrong?

share|improve this question
    
You don't have to sign with your name since it automatically appears in the lower right corner of your post. –  Papiro May 1 '13 at 13:37
2  
If you are using the code that you linked you should be using biber as the backend (and not BibTeX). –  ach May 1 '13 at 13:55
    
Are you using the \bibliography{your bib file goes here with no extension} command to pass your bib file? –  Sigur May 1 '13 at 13:58
    
You are using the package biblatex so I guess that bibtex is not the way to run your bibliography. –  Sigur May 1 '13 at 14:11
    
The problem was, as pointed out by ach, that the backend was not BiBTeX. I changed the line to \usepackage[backend=bibtex]{biblatex} and it worked just fine. Thanks ach. –  Alejandro Marcos Aragon May 1 '13 at 14:14

1 Answer 1

As written in the comments the default backend of biblatex2 and higher is biber. To use the traditional backend bibtex you have to specify this as an option:

\usepackage[backend=bibtex]{biblatex}
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.