Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

This question already has an answer here:

I have the following issue with hyperref and accented characters that I can't work out:

\documentclass[12pt]{article}

\usepackage[utf8]{inputenc}
\usepackage{hyperref}

\begin{document}

\href{http://epfl.academia.edu/AlejandroAragón}{my academic profile}

\href{http://epfl.academia.edu/AlejandroArag\'{o}n}{my academic profile}

\href{http://epfl.academia.edu/AlejandroAragón}{my academic profile}

\end{document} 

None of the resulting links take me to the right link in the browser, and actually the first two are disabled (they don't do anything). Am I missing something?

SOLUTION

I just replaced it by the following line:

\href{http://epfl.academia.edu/AlejandroArag\%C3\%B3n}{my academic profile}
share|improve this question

marked as duplicate by doncherry, egreg, Werner, T. Verron, Xavier May 1 '13 at 18:05

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer 1

You are missing \usepackage[T1]{fontenc} before \usepackage[utf8]{inputenc}

If you run this:

\documentclass[12pt]{article}

\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{hyperref}

\begin{document}

\href{http://epfl.academia.edu/AlejandroAragón}{my academic profile}

\href{http://epfl.academia.edu/AlejandroArag\'{o}n}{my academic profile}

\href{http://epfl.academia.edu/AlejandroAragón}{my academic profile}

\end{document} 

Your output will have link 1 and 2 working perfectly. Link 3 seems broken.

share|improve this answer
    
No, that didn't work. –  Alejandro Marcos Aragon May 1 '13 at 17:33
    
It's working for me here... I get to this page: epfl.academia.edu/AlejandroArag%F3n –  Mario S. E. May 1 '13 at 17:35
1  
It’s working for me as well, actually no matter if before or after inputenc. Is there a reason you specified the placement, @Mario? –  doncherry May 1 '13 at 17:41
    
@doncherry Yes :). Take a look here: tex.stackexchange.com/a/44699/27833 –  Mario S. E. May 1 '13 at 17:44
1  
@AlejandroMarcosAragon did you try what is said in this link? tex.stackexchange.com/questions/65422/… –  Mario S. E. May 1 '13 at 18:57

Not the answer you're looking for? Browse other questions tagged or ask your own question.