TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I created a class of my own that uses book as base class.

\ProvidesClass{manuscript}[2013/03/23 Creative writing manuscripts class]

The problem is that I want to be able to choose paper size and other options the book class has. The only way to do that is to redefine all the options the book class already has with the same values and pass it when I load the base class?

Also, let's say I want to add a language option to my class so that if I choose Portuguese, for example, I want to load babel with portuguese.

How can I create use the options already defined in book class to change the values of that class and use my new Portuguese option to load babel with that language.

share|improve this question

You can use


to pass all not used option to your basic class book when it is called with \LoadClass{book}.

To give you a better advice you should add a MWE what you doing in your class.

share|improve this answer
Ah, understood. And what about the babel package? My idea was to use \documentclass[portuguese,a4paper,12pt,oneside]{newClass} And get just the portuguese option to make something like \usepackage[portuges]{babel} with that option instead hardcoding it inside the class. – Psicofrenia May 3 '13 at 8:26
Btw, here's the source code of my class github.com/efernandespt/Manuscript/blob/master/manuscript.cls I'm trying to use \DeclareOption*{\PassOptionsToClass{\CurrentOption}{book}} \LoadClass{book} and get this error \RequirePackage or \LoadClass in Options selection – Psicofrenia May 3 '13 at 9:20
@Psicofrenia There is a problem with babel, languages as options of babel and languages as options of your documentclass. I suppose you will always use language portuges: so write a explicite call of babel in your class with \usepackage[portuges]{babel}. If you need to use options test your class carefully: there may be some astonishing behaviour ... It could be, that a language given in the options of your class or of babel is not working. For example I had often problems with the correct active language ... – Kurt May 3 '13 at 11:57
@Psicofrenia just a hint because I saw \usepackage{ae,aecompl} in your class: package ae is outdated. Please have a look into l2tabu.pdf eith command texdoc l2tabu or search package l2tabuon CTAN. – Kurt May 3 '13 at 12:08

To pass the options, use

\ProcessOptions \relax

To pass a new option to another package (in this case babel)

\RequirePackage[portuges, english]{babel}
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.