Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

in my Bibtex file i name the Author: author={R{\"o}{\ss}ler, Irene and Ungerer, Albrecht}, but in the literature list it strangely outputs this:

[Rößler und Ungerer 2012] RÖSSLER, Irene; UNGERER, Albrecht:...

where the second RÖSSLER should also be RÖßLER

Update2: MWE

\documentclass[a4paper,12pt,fleqn,oneside,numbers=noendperiod,headings=normal,appendixprefix=true,bibliography=totoc,listof=totoc]{article}
\usepackage{natbib}
\usepackage[ngerman]{babel}
\usepackage[latin1]{inputenc}
\usepackage[T1]{fontenc}

\begin{document}

Standardnormalverteiung ben\"otigt (\citep[S. 123]{mathe}).

\bibliographystyle{dinat}
\bibliography{MeineBib}

\end{document}

MeineBib:

@incollection{mathe,
year={2012},
booktitle={Statistik für Wirtschaftswissenschaftler},
series={BA KOMPAKT},
title={Wahrscheinlichkeitsrechnung},
publisher={Springer Berlin Heidelberg},
author={R{\"o}{\ss}ler, Irene and Ungerer, Albrecht},
pages={83-136},
language={German}
}
share|improve this question
    
Welcome to TeX.SX! I guess you are using the wrong document class. All options are related to scrartcl instead of article. Please add a minimal working example (MWE) that illustrates your problem. It will be much easier for us to reproduce your situation and find out what the issue is when we see compilable code, starting with \documentclass{...} and ending with \end{document}. –  Marco Daniel May 13 '13 at 18:27
    
Duplicate of How to code ß (German "sharp S") in BibTeX? –  Alan Munn May 13 '13 at 18:28
2  
If you are getting this output then you need to show exactly a small complete document that shows the problem. Can you also paste the exact entry from your .bib file. I suspect you have an extra space there, perhaps. –  Alan Munn May 13 '13 at 18:35
1  
@Simifilm the extra space in the output is his problem, but to understand that one needs a full MWE ... something fishy here –  Frank Mittelbach May 13 '13 at 18:36
2  
The posted .bib file contains a ~ after {\ss}. This will give a hard coded space; it should simply be removed. –  Andrew Swann May 13 '13 at 18:51
show 9 more comments

closed as too localized by mafp, lockstep, doncherry, Kurt, Thorsten May 13 '13 at 19:15

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

up vote 2 down vote accepted

The error is in your entry. You are typing: R{\"o}{\ss}~ler. However the token ~ forces a space. So simple write: R{\"o}{\ss}ler.

Here the correct entry:

@incollection{mathe,
 year={2012},
 isbn={978-3-642-32256-3},
 booktitle={Statistik für Wirtschaftswissenschaftler},
 series={BA KOMPAKT},
 doi={10.1007/978-3-642-32257-0_4},
 title={Wahrscheinlichkeitsrechnung},
 url={http://dx.doi.org/10.1007/978-3-642-32257-0_4},
 publisher={Springer Berlin Heidelberg},
 author={R{\"o}{\ss}ler, Irene and Ungerer, Albrecht},
 pages={83-136},
 language={German}
}

The following options only work with a KOMA class. In your case it ought be scrartcl.

 numbers=noendperiod,headings=normal,%
 appendixprefix=true,bibliography=totoc,
 listof=totoc

Here a correct mwe

\documentclass[a4paper,12pt,fleqn,oneside,%
     numbers=noendperiod,headings=normal,%
     appendixprefix=true,bibliography=totoc,
     listof=totoc]%
{scrartcl}
\usepackage{natbib}                                        
\usepackage[ngerman]{babel}                               
\usepackage[latin1]{inputenc} %Spezialzeichen in Tex-Code
\usepackage[T1]{fontenc}
\usepackage{hyperref}
\usepackage{filecontents}
\begin{filecontents}{MeineBib.bib}
@incollection{mathe,
 year={2012},
 isbn={978-3-642-32256-3},
 booktitle={Statistik für Wirtschaftswissenschaftler},
 series={BA KOMPAKT},
 doi={10.1007/978-3-642-32257-0_4},
 title={Wahrscheinlichkeitsrechnung},
 url={http://dx.doi.org/10.1007/978-3-642-32257-0_4},
 publisher={Springer Berlin Heidelberg},
 author={R{\"o}{\ss}ler, Irene and Ungerer, Albrecht},
 pages={83-136},
 language={German}
}
\end{filecontents}

\begin{document}

Standardnormalverteiung ben\"otigt (\citep[S. 123]{mathe}).

\bibliographystyle{dinat}
\bibliography{MeineBib}

\end{document}

enter image description here

share|improve this answer
    
Thank you, but the second entry "RÖSSLER" is still with SS instead of ß im new to this and im trying my best. sorry for any inconveniences caused by my poor forum skills :) –  Sid May 13 '13 at 19:05
    
Anyway i found out that SS in the "small capitals" font is the correct translation for ß. I didnt know that :D. Thank you Marco for your answer. –  Sid May 13 '13 at 19:09
2  
@Sid officially there is no uppercase “ß” and also no small caps “ß” and “SS” is orthographically correct there. (Some fonts do have uppercase and sc versions of “ß”, though...) –  cgnieder May 13 '13 at 19:19
2  
@Sid If you want an uppercase ß (ẞ – ), you can use XeLaTeX and the packages fontspec and libertine: i.stack.imgur.com/XMGvh.png –  doncherry May 13 '13 at 19:29
    
@doncherry Go, libertine! :) (The ẞ could be kerned a little bit closer to the ö, though... or the small caps could be spaced out more... or both...) –  cgnieder May 13 '13 at 20:16
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.