TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to get a custom document class working on a Windows PC where I do not have administrative rights. MikTex can't access its package repository, and so far I've been forced to install a large amount of packages by hand which is really time consuming.

Now, when I try to compile my document, I run into this bug:

Command Line:   pdflatex.exe --interaction=errorstopmode --synctex=-1 "main.tex"
Startup Folder: C:\Users\x\Downloads\rtthesisex-exjobb\rtthesisex

This is pdfTeX, Version 3.1415926-2.4-1.40.13 (MiKTeX 2.9)
entering extended mode
LaTeX2e <2011/06/27>
Babel <v3.8m> and hyphenation patterns for english, afrikaans, ancientgreek, ar
abic, armenian, assamese, basque, bengali, bokmal, bulgarian, catalan, coptic, 
croatian, czech, danish, dutch, esperanto, estonian, farsi, finnish, french, ga
lician, german, german-x-2012-05-30, greek, gujarati, hindi, hungarian, iceland
ic, indonesian, interlingua, irish, italian, kannada, kurmanji, latin, latvian,
 lithuanian, malayalam, marathi, mongolian, mongolianlmc, monogreek, ngerman, n
german-x-2012-05-30, nynorsk, oriya, panjabi, pinyin, polish, portuguese, roman
ian, russian, sanskrit, serbian, slovak, slovenian, spanish, swedish, swissgerm
an, tamil, telugu, turkish, turkmen, ukenglish, ukrainian, uppersorbian, usengl
ishmax, welsh, loaded.
----- SNIP (loading packages) -----
Option `squaren' provided!
)) (C:\Users\x\Downloads\rtthesisex-exjobb\rtthesisex\main.aux)
("C:\Program Files\MiKTeX 2.9\tex\latex\base\ts1cmr.fd")
miktex-maketfm.exe: Try Again
miktex-maketfm.exe: Data: get host by name failed in tcp_connect()
Running miktex-makemf.exe...
miktex-makemf: The jkpmn8t source file could not be found.

Running hbf2gf.exe...

hbf2gf (CJK ver. 4.8.0)

Couldn't find `jkpmn.cfg'

miktex-maketfm: No creation rule for font jkpmn8t.

! Font T1/jkpk/m/n/10=jkpmn8t at 10.0pt not loadable: Metric (TFM) file not fou
<to be read again> 
l.17 \begin{document}

? x
No pages of output.
Transcript written on main.log.


 PDFLaTeX Compilation Report (Pages: 0)

 Errors: 1   Warnings: 1   Bad Boxes: 0

I have no idea how to fix this manually. I have tried reinstalling the package, but there are no .cfg files included in kpfonts. Does anyone have another idea?

share|improve this question
Welcome to TeX.SX! You may have a look on our starter guide. – texenthusiast May 14 '13 at 6:41
See also Manual font installation. – Speravir May 22 '13 at 21:23

You don't need to install everything by hand. Create a local repository. You need the two miktex-zz...-files and the miktex packages you want to install. Put everything in some folder and then use this folder. For details see e.g. MiKTeX: [...] does not seem to be a local package repository.

Ignore the message about a .cfg file. maketfm is looking for it as a last resort. The real problem is the missing .tfm file. You probably put it in the wrong place. All the .fd files are in the wrong folder too: They belong in tex\latex\kpfonts.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.