Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

EDIT:

I changed the Modkey of my window manager, so that it doesn't rely on the ALT key anymore and no remapping of keys for latex-suite is necessary.

Mapping CTRL+i didn't work but any other key combination does.


I try to map Alt+i for inserting the item element to C+i.

So I followed the instructions from the latex-suite manual, which states that the Alt-key mappings belong into the $VIM/ftplugin/tex.vim file. I put the following line into the file tex_latexSuite.vim that is being read when a .tex file is edited by vim also created a softlink for tex.vim.

imap <c-i> <Plug>Tex_InsertItemOnThisLine

OK at first it kind of worked. By pressing c+i it inserted the item element but also when i did hit Tab. And sometimes I could see a message, when a .tex file is being, that states the Tab key has been mapped to the <Plug>Tex_InsertItemOnThisLine in the tex_latexSuite.vom file Oo.

I also tried it with

:verbose imap <Tab>

in ~/.vimrc but that doesn't work either.

Ok so either the Tab key works as expected or by adding the wanted mapping it doesn't work at all, also does c+i or both mappings insert item on the current line.

share|improve this question
    
Mapping this function to another combination works fine. –  wottis May 14 '13 at 13:12
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.