Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have a biblatex reference with a URL field. However, every backslash is surrounded by spaces.

I am using

\usepackage[sorting=nyt, citestyle=authoryear, bibstyle=authoryear, isbn=false, firstinits=true, url=false, terseinits=true, dashed=false, maxcitenames=3, maxbibnames=99, backref=true, doi=false]{biblatex}

What causes this, and how can I remove them?

EDIT: MWE

My biblatex .bib file is this:

@ONLINE{Soderberg2010,
author = {Soderberg, T},
title = {Section 5.1: The origin of the {NMR} signal.},
year = {2010},
url = {http://chemwiki.ucdavis.edu/Organic_Chemistry/Organic_Chemistry_With_a_Biological_Emphasis/Chapter__5%3A_Structure_Determination_II/Section_5.1%3A_The_origin_of_the_NMR_signal},
urldate = {2013-5-16}
}

This works:

\documentclass[11pt]{amsart}
\usepackage{geometry}                % See geometry.pdf to learn the layout options. There are lots.
\geometry{letterpaper}                   % ... or a4paper or a5paper or ... 
%\geometry{landscape}                % Activate for for rotated page geometry
%\usepackage[parfill]{parskip}    % Activate to begin paragraphs with an empty line rather than an indent
\usepackage{graphicx}
\usepackage{amssymb}
\usepackage{epstopdf}
\DeclareGraphicsRule{.tif}{png}{.png}{`convert #1 `dirname #1`/`basename #1 .tif`.png}
\usepackage{multicol}

\usepackage[sorting=nyt, citestyle=authoryear, bibstyle=authoryear, isbn=false, firstinits=true, url=false, terseinits=true, dashed=false, maxcitenames=3, maxbibnames=99, backref=true, doi=false]{biblatex}
\addbibresource{resourcename}


\title{Brief Article}
\author{The Author}
%\date{}                                           % Activate to display a given date or no date

\begin{document}
\maketitle
%\section{}
%\subsection{}

\begin{multicols*}{2}
\parencite{Soderberg2010}
\end{multicols*}{2}

\printbibliography

\end{document} 

This doesn't work:

\documentclass[11pt]{amsart}
\usepackage{geometry}                % See geometry.pdf to learn the layout options. There are lots.
\geometry{letterpaper}                   % ... or a4paper or a5paper or ... 
%\geometry{landscape}                % Activate for for rotated page geometry
%\usepackage[parfill]{parskip}    % Activate to begin paragraphs with an empty line rather than an indent
\usepackage{graphicx}
\usepackage{amssymb}
\usepackage{epstopdf}
\DeclareGraphicsRule{.tif}{png}{.png}{`convert #1 `dirname #1`/`basename #1 .tif`.png}
\usepackage{multicol}

\usepackage[sorting=nyt, citestyle=authoryear, bibstyle=authoryear, isbn=false, firstinits=true, url=false, terseinits=true, dashed=false, maxcitenames=3, maxbibnames=99, backref=true, doi=false]{biblatex}
\addbibresource{resourcename}


\title{Brief Article}
\author{The Author}
%\date{}                                           % Activate to display a given date or no date

\begin{document}
\maketitle
%\section{}
%\subsection{}

\begin{multicols*}{2}
\parencite{Soderberg2010}
\end{multicols*}{2}

\begin{multicols*}{2}
\printbibliography
\end{multicols*}{2}

\end{document}

The only difference is that the second document has the reference list inside multicols.

share|improve this question
2  
Please add to your question a minimal working example illustrating the problem. –  Gonzalo Medina May 16 '13 at 2:01
    
Minimal working example added. –  daviewales May 16 '13 at 3:44
    
The extra letter spacing is due to the fact that the bibliography text is justified. You can see this if you switch to ragged right text with \appto{\bibsetup}{\raggedright} in your preamble. –  Audrey May 16 '13 at 17:39

2 Answers 2

up vote 4 down vote accepted

biblatex gives some small stretchability in URL breaking using url package \Urlmuskip parameter. This is there whether or not multicolumn is used, it's just that in the narrow measure of a multi column setting the stretchability is more likely to be used if available.

There is probably a higher level biblatex setting for this, but this just patches the setup command to reset the parameter to zero.

adding this to your preamble

\toks0\expandafter{\biburlsetup}
\edef\biburlsetup{\the\toks0 \Urlmuskip =0mu\relax}

produces

enter image description here

share|improve this answer
    
Thanks for that! =D –  daviewales May 17 '13 at 0:54

I discovered that the problem was due to multicolumn. My solution was to disable multicolum for the reference list. If anyone has a solution that doesn't require disabling multicolumn for the reference list I will be very interested.

share|improve this answer
1  
Kindly add the MWE as requested by Gonzalo Medina. It will add value to the Question and Answer while benefiting others to post new answers and future users. I are not aware of how multicolumn was a problem and how disabling resolved it because of absence of sample code ?. MWE is first step to diagnosis of errors/issues –  texenthusiast May 16 '13 at 2:06
    
Minimal working example added. –  daviewales May 16 '13 at 3:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.