Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am writing a small KOMA-Script scrartcl document with multiple sections. In the table of contents, LaTeX fills the current line with dots between the end of the section name and the page number. Is there any way to customize this behavior? I would like to reduce the space between the single dots (i.e. use more dots in the same space).

share|improve this question
1  
örn: that's not the default behavior of scrartcl. Section titles would be set without dots, subsections would produce dotted TOC lines. Perhaps show your settings, the best would be a minimal example. –  Stefan Kottwitz Feb 20 '11 at 14:32
    
Yes, you are right. Actually, I am referring to subsections (and subsubsections). However, this is a general question that is also interesting for other document classes. –  Björn Marschollek Feb 20 '11 at 14:39
add comment

1 Answer

up vote 7 down vote accepted

For dotted TOC lines, standard LaTeX and also KOMA-Script use the internal macro \@dotsep which specifies that space in mu. Its original value is 4.5.

You could adjust it this way:

\makeatletter
\renewcommand*{\@dotsep}{1}
\makeatother
share|improve this answer
    
It would be helpful if you also specified the default setting. –  lockstep Feb 20 '11 at 14:44
    
@lockstep: Right! I thought the same and added it, right at the same time of your comment I guess. :-) I used \show\@dotsep first. Then I cross-checked: it's usually defined by the class, for example by \newcommand\@dotsep{4.5} in the base classes. –  Stefan Kottwitz Feb 20 '11 at 14:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.