TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to compile a .tex file using pdflatex and I get the following two kinds of errors:

Package natbib Warning: Citation `give-citation' on page 14 undefined on input line 41.

! Undefined control sequence.
<argument> ...e \NAT@cmt \fi \if \relax \NAT@date \relax \else \NAT@@close \...
 l.46 ... information is available \cite{}

It works smoothly with pdflatex on my mac.

Another error that I get on this linux box (again using pdflatex) is:

 ! LaTeX Error: Unknown graphics extension: .eps.

 See the LaTeX manual or LaTeX Companion for explanation.
 Type  H <return>  for immediate help.
 l.12 ...\includegraphics[width=4.2in]{tree.eps}

These errors appear quite frequently, they are all over the document. Is it possible to fix them?

share|improve this question

The Undefined control sequence is because a macro is not defined. Most likely one of your packages (natbib or a related one) is outdated. Simply update your LaTeX installation and try it again. Also have a look in the log file for warnings which sound like "package has been requested in version <...> but only version <...> was found" or similar.

The second error is because you are trying to use a EPS with pdflatex which doesn't support this format. Either convert this file to a PDF using e.g. the epstopdf program or you can load the epstopdf package to do this automatically. This however requires that the option -shell-escape is used.

share|improve this answer
And here the difference between the Mac and the Linux box might be that e.g. TeXShop defaults to enabling \write18 (which allows external programs to be run); other systems/editor combinations might not allow this, even with the epstopdf package loaded. – Alan Munn Feb 21 '11 at 0:00
@Alan: Thanks Alan, I forgot to mention that in my answer. – Martin Scharrer Feb 21 '11 at 0:02

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.