Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

texlive 2012 debian package:

\documentclass[]{article}%
\usepackage{amsmath}   
\begin{document}  
\begin{align}
      &    \uparrow\sum F
\end{align}
\end{document}

compile with

htlatex report.tex "htm,mathml" " -cunihtf" 

gives

/usr/share/texmf/tex/generic/tex4ht/html-mml.4ht) 
(/usr/share/texmf/tex/generic/tex4ht/html4-uni.4ht)) 
(./report.aux) 
! Bad mathchar (79119). <argument>  & \uparrow \sum F 
                               l.8 \end{align}
                ?

But when compile as

 htlatex report.tex "htm,xhtml" " -cunihtf" 

or

 htlatex report.tex "htm" " -cunihtf" 

No error.

What should I do? Is this a bug in htlatex? any workaround? The problem happens when using \uparrow with mathml and when using align. Without align there is no error.

\documentclass[]{article}%
\usepackage{amsmath}   
\begin{document}  
    $\uparrow\sum F$
\end{document}

Now

  htlatex report.tex "htm,mathml" " -cunihtf"

No error.

update

fyi, if you are using htlatex with mathml watch out for align. Workaround I found for now is to use eqnarray. Now the errors went away. I am trying to compile to HTML code generated by Scientific word, which generated the align Latex code. So I had to edit the code and change all the align to eqnarray as temporary fix for now to get HTML generated.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.