Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am trying to place two images in top of two columns in a columns environment, in a beamer presentation.

The first column consists of one image on top and a enumeration list bellow the image.

The thing is that I want the column to start at the top of the frame, which isn't happening in my case. My code is

\documentclass[slidestop,compress,mathserif,11pt,xcolor=dvipsnames]{beamer}
\usepackage{beamerthemebars}
\usepackage[bars]{beamerthemetree}
\usepackage{multicol}
\setbeamercovered{higly dynamic}
\usetheme{Ilmenau} % Beamer theme v 3.0
\useoutertheme[subsection=true]{smoothbars}%Beamer Outer Theme-circles on top
\usefonttheme{serif}
\useinnertheme{circles}

\begin{document}
        \section{Εισαγωγή}
\begin{frame}
        \frametitle{Nuclear Propulsion}
        \begin{columns}
                \begin{column}{0.48\textwidth}
                        \begin{figure}[t]
                        \includegraphics[width=\textwidth]{AtomicSubmarine}%\vspace{0.5cm}
                        \end{figure}
                        \tiny{\begin{enumerate}
                                \item Item1$\rightarrow$ Conclusdion
                                \item Item2$\rightarrow$ Conclusdion
                                \item Item3$\rightarrow$ Conclusdion
                                \item Item4$\rightarrow$ Conclusdion
                                \item Item5$\rightarrow$ Conclusdion
                                \item Item6$\rightarrow$ Conclusdion
                        \end{enumerate}}
                        %\begin{minipage}[t]{0.99\textwidth}
                                %\includegraphics[width=\textwidth]{AtomicSubmarine}
                        %\end{minipage}
                \end{column}\hfill
                \begin{column}{0.48\textwidth}
                        %\begin{minipage}[b]{0.99\textwidth}
                        \begin{figure}[t]
                                \includegraphics[width=0.9\textwidth]{SubmarineSnorkel}
                        \end{figure}
                        %\end{minipage}
                \end{column}
        \end{columns}
        %\begin{minipage}[b]{0.5\textwidth}
                %\includegraphics[width=\textwidth]{SubmarineSnorkel}
        %\end{minipage}
\end{frame}
\end{document}

The output of this code is

enter image description here

It is clear that a few lines upper would be ideal, as the real presentation frame, states!

enter image description here

I've tried to remove the figure environment, to use minipage but the right image is aligned with the list, resulting in a very bad format. One solution is to remove the frametitle but I'm afraid I need it...

Another idea is to use \vspace{-1cm} but I am not sure if this is the optimum solution...

Any ideas on that?

share|improve this question

1 Answer 1

up vote 5 down vote accepted

See section 12.7 (Splitting a Frame into Multiple Columns) of the beamer manual:

t will cause the first lines of the columns to be aligned. Default if global option t is used.

T is similar to the t option, but T aligns the tops of the first lines while t aligns the so-called baselines of the first lines. If strange things seem to happen in conjunction with the t option (for example if a graphic suddenly “drops down” with the t option instead of “going up,”), try using this option instead.

I see you commented out some minipage environment. No need to use minipage in conjunction with column, because the latter uses the former internally. You should be able to achieve any multiple-column layout you want with just columns and column environments, without (explicitly) using minipage.

enter image description here

\documentclass[slidestop,compress,mathserif,11pt,xcolor=dvipsnames]{beamer}
\usepackage{beamerthemebars}
\usepackage[bars]{beamerthemetree}
\usepackage{multicol}
\setbeamercovered{higly dynamic}
\usetheme{Ilmenau} % Beamer theme v 3.0
\useoutertheme[subsection=true]{smoothbars}%Beamer Outer Theme-circles on top
\usefonttheme{serif}
\useinnertheme{circles}

\begin{document}
\section{Εισαγωγή}
\begin{frame}
\frametitle{Nuclear Propulsion}
    \begin{columns}
      \begin{column}[T]{0.48\textwidth}
      \vspace{0pt}%
        \includegraphics[width=\columnwidth]{AtomicSubmarine}
        \vspace{1em}
        \tiny
        \begin{enumerate}
            \item Item1$\rightarrow$ Conclusdion
            \item Item2$\rightarrow$ Conclusdion
            \item Item3$\rightarrow$ Conclusdion
            \item Item4$\rightarrow$ Conclusdion
            \item Item5$\rightarrow$ Conclusdion
            \item Item6$\rightarrow$ Conclusdion
        \end{enumerate}
      \end{column}\hfill
      \begin{column}[T]{0.48\textwidth}
        \includegraphics[width=0.9\columnwidth]{SubmarineSnorkel}
      \end{column}
    \end{columns}
\end{frame}

\end{document}
share|improve this answer
    
Thank you very much!!! Now it's working like a charm!!! Thank's! –  Thanos May 29 '13 at 15:32
    
You can use figure and table in beamer without problems (in fact, if you want to have captions (which I don't like much but it is sometimes required), it's useful to have the possibility to use figure or table) since beamer internally deactivates the floating mechanism. –  Gonzalo Medina May 30 '13 at 2:12
    
@GonzaloMedina In my experience, figure and table modify the vertical spacing, though, which is a pain when you're trying to achieve precise positioning of the elements on your frame. But alright, I'll modify my answer accordingly. –  Jubobs May 30 '13 at 9:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.