Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

As the title says, the command \footfullcite{test} does not give the full citation, but only the label "test", "test1" and "test2", respectively. I'm using biblatex and the beamer class (downloaded yesterday, so hopefully the newest versions).

Any ideas? :(

Code:

\documentclass{beamer}

\usepackage{pgf}
\usepackage{xcolor}
\usepackage[utf8]{inputenc}
\usepackage[style=authortitle]{biblatex}

\usepackage{filecontents}

\begin{filecontents}{vorlage.bib}

 @article{test1,
    author  = {Shen Lin and Brian W. Kernighan},
    title   = {An Effective Heuristic Algorithm for the Travelling-Salesman Problem},
    journal = {Operations Research},
    volume  = {21},
    year    = {1973},
    pages   = {498--516},
 }

@BOOK{test,
  title = {The Infamous Test},
  publisher = {Testington Test},
  year = {2007},
  author = {John Doe},
  address = {Testville},
}

@ARTICLE{test2,
  author = {Testi, T.},
  year = {2003},
  title = {Testartikel},
  journal = {Testjournal}
}
\end{filecontents}
\addbibresource{vorlage.bib}

\begin{document}

\begin{frame}
\frametitle{Introduction and motivation - the title}
\section[Motivation]{Introduction and motivation}
test text \footfullcite{test}\\test text 1 \footfullcite{test1}\\test text 2 \footfullcite{test2}
\end{frame}

\end{document}

here the result:

beamer slide

share|improve this question

closed as too localized by Alan Munn, egreg, Paul Stanley, Werner, barbara beeton May 30 '13 at 20:09

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
Welcome to TeX.SX! You can have a look on our starter guide to familiarize yourself further with our format. –  Jubobs May 30 '13 at 9:11
1  
I think I get the desired output. Have you run pdflatex, then bibtex, then pdflatex twice? –  Jubobs May 30 '13 at 9:16
    
actually I used the MikTeX standard, which is pdfLaTeX + MakeIndex + BibTeX. I did this several times with and without deleting the .aux file. I also tried as you said: pdfLaTeX + BibTeX twice, but this doesn't change anything... –  Ulrike S. May 30 '13 at 17:31
1  
If your biblatex is up to date, it wants biber not biblatex. Either run biber or add backend=bibtex to the options when loading biblatex. –  Paul Stanley May 30 '13 at 19:23
    
@Paul: thank you a lot, it worked! :) –  Ulrike S. May 30 '13 at 19:36