Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I was previously able to run LaTeX with TeX Live 2011, but since installing TeX Live 2012, I get the error message ! I can't write on file 'texsys.aux'.

This is a Windows 7 operating system. I have tried processing a minimal working example from the command line using:

latex test.tex

The MWE

\documentclass{article}
\begin{document}
This is some text.
\end{document}    

The log file shows the following:

This is pdfTeX, Version 3.1415926-2.4-1.40.13 (TeX Live 2012/W32TeX) (INITEX)  4 JUN 2013 17:34
entering extended mode
restricted \write18 enabled.
%&-line parsing enabled.
(c:/texlive/2012/texmf/web2c/cp227.tcx)
***latex.ini
(c:/texlive/2012/texmf-dist/tex/latex/latexconfig/latex.ini
(c:/texlive/2012/texmf-config/tex/generic/config/pdftexconfig.tex)
(c:/texlive/2012/texmf-dist/tex/latex/base/latex.ltx
(c:/texlive/2012/texmf-dist/tex/latex/base/texsys.cfg)
! I can't write on file `texsys.aux'.
l.140 \immediate\openout15=texsys.aux

(Press Enter to retry, or Control-Z to exit; default file extension is `.tex')
Please type another output file name: 
! Emergency stop.
l.140 \immediate\openout15=texsys.aux
share|improve this question
2  
That's odd: it is not processing the file that you showed but rather the source of latex itself, in intex mode. I can't guess why. What happens if you use pdflatex sample2e as the command, do you get a sample2e.pdf ? –  David Carlisle Jun 4 '13 at 20:46
    
Thank you for your comment. I followed your suggestion and got the same error. –  Martin Clouthier Jun 4 '13 at 20:59
2  
I think the install failed and latex format was not made at install time (perhaps you didn't have write access to the directory) so every time you try to latex any file it is trying to make a latex format first and failing. –  David Carlisle Jun 4 '13 at 21:05
    
I re-installed and found 14 instances of "I can't write on file `texsys.aux' in the install-tl.log. I checked the log file for 2011 and found no errors. –  Martin Clouthier Jun 4 '13 at 22:38
2  
That figures: It is failing to make each format latex, pdflatex, luaatex etc. If it can't write it is an operating system level restriction not a tex one. Do you have admin rights (if installing for all users) or installing it in your area (if installing it under a normal account). I don't use the windows install so I can't be specific... –  David Carlisle Jun 4 '13 at 22:41

1 Answer 1

Ensure that you have full administrative privileges. In this case, my user ID belonged to the administrator group, but since the installation was taking place while the computer was not connected to the network (i.e., out of the office), administrator status could not be verified and privileges were restricted. IT staff was able to remotely login and run the installation successfully.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.