Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am using following set of packages for my LaTeX file but I am getting following error.

! LaTeX Error: Option clash for package placeins.
See the LaTeX manual or LaTeX Companion for explanation.
Type H <return> for immediate help.
... \begin`

The packages which I am using are

\documentclass[twocolumn]{svjour3}          % twocolumn
 \smartqed  % flush right qed marks, e.g. at end of proof
 \usepackage{graphicx, subfigure}
 \usepackage{amsmath}
 \usepackage{subfig}
 \sloppy
 \usepackage{placeins}
 \usepackage{textcomp}
 \usepackage[linesnumbered,ruled,vlined]{algorithm2e}
 \usepackage{algorithmicx}
 \usepackage{algpseudocode}
 \usepackage{tabularx}
 \usepackage[section]{placeins}

Which two packages are in conflict?

share|improve this question

1 Answer 1

The two packages conflicting are really one, since you load placeins twice, first without options and then with section option and this will produce the clash. Delete the one of the two lines loading the package (depending on whether you need or not the section option).

You could have discovered this by yourself had you typed h (for help) in the output console when the error appeared. After h + return you would get:

? h
The package placeins has already been loaded with options:
  []
There has now been an attempt to load it with options
  [section]
Adding the global options:
  ,section
to your \documentclass declaration may fix this.
Try typing  <return>  to proceed.
? 

Also, not in the question, but you are loading the obsolete subfigure package. Use subfig (which you are already loading) or subcaption instead.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.