Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I wanted to try biblatex, but even my minimal examples don't work:

\documentclass{article}
\begin{filecontents}{\jobname.bib}
@ONLINE{Doe:2009:Online,
author = {Doe, Ringo},
title = {This is a test entry of type {@ONLINE}},
month = jun,
year = {2009},
url = {http://www.test.org/doe/}
}
\end{filecontents}
\usepackage{biblatex}
\bibliography{\jobname.bib}
\title{BibTeX Website citations with the \textsf{biblatex}~package}
\date{}
\begin{document}
\maketitle
\nocite{Doe:2009:Online}
\printbibliography
\end{document}

I just do not get any output for my document. Is there anything I have to watch out for using MiKTeX? Where does the bib file have to be? Unfortunately, I haven't found anything on the internet in this regard.

share|improve this question
    
Welcome to TeX.SX! You can have a look on our starter guide to familiarize yourself further with our format. (I'ved edited to use filecontents to hold your .bib file: this makes it easier for people to try out your demo.) –  Joseph Wright Jun 7 '13 at 6:06
    
Do you really have \bibliography{<filename>.bib} rather than just \bibliography{<filename>}? The \bibliography command always adds .bib, so you should not use it. –  Joseph Wright Jun 7 '13 at 6:07
    
@JosephWright the command \bibliography is redefined by biblatex so you can use it with or without specifying the .bib extension –  karlkoeller Jun 7 '13 at 6:31
    
@karlkoeller No, the semantics remain the same: \bibliography for .bib files only or \addbibresource with a full file name. (BibTeX actually does the addition of .bib when it reads the .aux file.) –  Joseph Wright Jun 7 '13 at 6:33
    
@JosephWright From the biblatex manual: "\bibliography{<bibfile,...>}: The legacy command for adding bibliographic resources, supported for backwards compatibility. Like \addbibresource, this command is only available in the preamble and adds resources to the default resource list. Its argument is a comma-separated list of bib files. The .bib extension may be omitted from the filename. Invoking this command multiple times to add more files is permissible. This command is deprecated. Please consider using \addbibresource instead. –  karlkoeller Jun 7 '13 at 6:48

2 Answers 2

up vote 6 down vote accepted

The problem might be that you are compiling your bibliography with BibTeX. If you want to do that, you have to tell biblatex about this choice, i.e. load this package with the option backend=bibtex, in this way:

\usepackage[backend=bibtex]{biblatex}

Before trying to compile again, I suggest you to delete the .aux and .bbl files.

In this case, run

pdflatex test

bibtex test

pdflatex test

pdflatex test

Otherwise, leaving your document as is, you will need to compile your bibliography with biber and not with BiBTeX. In this case, I also suggest you to replace

\bibliography{test.bib}

with

\addbibresource{test.bib}

to accomplish biblatex recommendations.

In this case, run

pdflatex test

biber test

pdflatex test

pdflatex test

share|improve this answer
    
From the question it's not clear to me whether he knows that he actually has to run bibtex. The sequence with biblatex is (pdf)latex, bibtex/biber, pdflatex. –  Simifilm Jun 7 '13 at 6:14
    
@Simifilm I've added it in the answer –  karlkoeller Jun 7 '13 at 6:52
    
Thanks, the change to bibtex did work. I only have to run the MikTex Compiler once though, I assume it does all the necessary work for me. –  chaosflaws Jun 7 '13 at 10:37
    
@user31863: Instead of using [backend=bibtex] you should better try to find out how to call biber instead of bibtex in your workflow. biber is much more powerful and quite a lot of features of biblatex relies on it. –  Ulrike Fischer Jun 7 '13 at 15:15
    
@chaosflaws BTW, what do you mean with MiKTeX Compiler? –  karlkoeller Jun 8 '13 at 6:23

I had similar problem, turned out the 64bit version of miktex did not have biber.

share|improve this answer
    
Welcome to TeX.SX! You can have a look on our starter guide to familiarize yourself further with our format. –  Claudio Fiandrino Jun 8 '13 at 15:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.