Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I write a package named umtools.sty, since Ubuntu One can only sync the folder which is in ~/, so I put *.sty in ~/tlpkg/.

Now, how can I use it like \usepackage{umtools} instead of \usepackage{~/tlpkg/umtools}, as the way it is set up, \usepackage{<absolute path>} causes a warning: "You have requested package `~/tlpkg/umtools', but the package provides umtool", which makes me uncomfortable.

I've tried to modify ~/.pam_environment to add new PATH, but it doesn't work. Does someone know kpathsea.

Ubuntu 13.04 + Tex Live 2012 by sh install_tl + TeXstudio + XeTeX

share|improve this question
    
mkdir -p ~/texmf/tex/latex && mv ~/tlpkg/umtools.sty ~/texmf/tex/latex/. ~/texmf is the proper local/personal directory; but make it mimic a proper 'tex tree' directory structure. –  jon Jun 7 '13 at 18:36
1  
Welcome to TeX.SX! Your post was migrated here from another Stack Exchange site. Please register on this site, too, and make sure that both accounts are associated with each other (by using the same OpenID), otherwise you won't be able to comment on or accept answers or edit your question. –  Joseph Wright Jun 8 '13 at 5:13
    
Please Read The Fine Manual‌​. –  Martin Schröder Jun 9 '13 at 14:49
add comment

migrated from askubuntu.com Jun 7 '13 at 18:18

This question came from our site for Ubuntu users and developers.

1 Answer

You have two options:

  1. Put them in a standard directory where TeX will look:

    ~/texmf/tex/latex/umtools

    You may need to run texhash afterwards.

  2. Set the env. variable TEXINPUTS. (just like you'd set $PATH). I prefer to set it to something like this:

    TEXINPUTS=.:./packages:$HOME/texmf

    which gives me the flexibility of what package to use for a project:

    1. First check in the current working directory (for small projects)
    2. Then check in the sub directory packages
    3. Then check in ~/texmf
    4. And finally use the distribution default package.
share|improve this answer
    
Welcome to TeX.sx!! –  Papiro Jun 7 '13 at 20:02
1  
TeX Live 2012 doesn't require texhash on your 'local' tree unless it's on a remote file system. –  Joseph Wright Jun 8 '13 at 5:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.