Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have the same problem as this question: Cannot compile using the newpx package

But the solution there doesn't work for me. After running updmap several times I still can't compile even the simple

\documentclass{article}
\usepackage{newpxtext}
\begin{document}
test
\end{document}

I get the error:

!pdfTeX error: pdflatex.EXE (file T1-TeXGyrePagellaX-Regular-lnum-kern-liga--base):
Font T1-TeXGyrePagellaX-Regular-lnum-kern-liga--base at 600 not found
 ==> Fatal error occurred, no output PDF file produced!

I tried updmap --force and --admin too. I'm using MiKTeX 2.9.

share|improve this question
    
Which LaTeX distribution? Compiles just fine for me using TUG TeX Live 2012 (frozen). –  daleif Jun 12 '13 at 14:29
    
@daleif MiKTeX 2.9 –  marczellm Jun 12 '13 at 14:35
    
How did you install the font? I tend to recommend TUG TL to my users as it adds everything and it just works. Lots of people seem to have problems with either MikTeX or the Ubuntu version of TL. –  daleif Jun 12 '13 at 14:36
    
@daleif I will now try to reinstall it with the built-in package manager, because it's possible that it was an on-the-fly install during compilation which MiKTeX automatically does, although the installation procedure should be the same. –  marczellm Jun 12 '13 at 14:41
    
Might be an idea. You could test to see if it finds some of the font files, e.g. kpsewhich TeXGyrePagellaX-Regular.pfb –  daleif Jun 12 '13 at 14:45

1 Answer 1

up vote 3 down vote accepted

I uninstalled the newpx package, ran a full update of MiKTeX, and reinstalled the package. Then the compilation failed with an etex.sty not found error. I had to install the package miktex-etex-base-2.9 from the package manager because the earlier miktex-etex-base has been removed as obsolete during the update. After that everything worked again.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.