Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I cite some things in footnotes, and want to cite some other things in bibliography using a numbered style. I have to use biblatex-gost style, and it provides the functionality.

But I get issue: bibliography counter doesn't start with 1. I tried to reset it using solutions found here. But it doesn't work. Neither

\usepackage[
...
defernumbers=true,
...
]{biblatex}

...

\printbibliography[resetnumbers=true, notkeyword=footcited]

works.

Here's an MWE:

\documentclass{article}

\usepackage{fontspec} % enagles loading of OpenType fonts
\usepackage{polyglossia} % support for languages

% fonts:
\defaultfontfeatures{Scale=MatchLowercase,Mapping=tex-text} % without this XeLaTeX won't turn "--" into dashes
\setmainfont{DejaVu Sans}
\setsansfont{DejaVu Sans}
\setmonofont{DejaVu Sans Mono}

% Russian/English document:
\usepackage{xecyr}
\newfontfamily\cyrillicfont{DejaVu Sans}
\setmainlanguage{russian} % \setdefaultlanguage{russian} is obsolete and not needed
\setotherlanguage[variant=american]{english}

% bibliography:
\usepackage[
    backend=biber,
    minnames=3,
    citestyle=gost-footnote-min,
    bibstyle=gost-numeric-min,
    url=false,
    sorting=none,
    language=auto,
    babel=other,
]{biblatex}

\usepackage{filecontents}

\begin{filecontents}{\jobname.bib}
@misc{A01,
  author = {Author, A.},
  year = {2001},
  title = {Alpha},
  keywords = {footcited},
}
@misc{B02,
  author = {Buthor, B.},
  year = {2002},
  title = {Bravo},
}
@misc{C03,
  author = {Cuthor, C.},
  year = {2003},
  title = {Charlie},
}
\end{filecontents}

\addbibresource{\jobname.bib}

\begin{document}

Text\footcite{A01}.

\nocite{B02, C03}

% bibliography:
\printbibliography[notkeyword=footcited]

\end{document}

Result:

enter image description here

Edit:

No Russian, no biblatex-gost MWE with resetnumbers:

\documentclass{article}

\usepackage{fontspec} % enagles loading of OpenType fonts
\usepackage{polyglossia} % support for languages

% fonts:
\defaultfontfeatures{Scale=MatchLowercase,Mapping=tex-text} % without this XeLaTeX won't turn "--" into dashes
\setmainfont{DejaVu Sans}
\setsansfont{DejaVu Sans}
\setmonofont{DejaVu Sans Mono}

\setmainlanguage{english} % \setdefaultlanguage{russian} is obsolete and not needed

% bibliography:
\usepackage[
    backend=biber,
    minnames=3,
    url=false,
    sorting=none,
    language=auto,
    babel=other,
    defernumbers=true,
]{biblatex}

\usepackage{filecontents}

\begin{filecontents}{\jobname.bib}
@misc{A01,
  author = {Author, A.},
  year = {2001},
  title = {Alpha},
  keywords = {footcited},
}
@misc{B02,
  author = {Buthor, B.},
  year = {2002},
  title = {Bravo},
}
@misc{C03,
  author = {Cuthor, C.},
  year = {2003},
  title = {Charlie},
}
\end{filecontents}

\addbibresource{\jobname.bib}

\begin{document}

Text\footcite{A01}.

\nocite{B02, C03}

% bibliography:
\printbibliography[resetnumbers=true, notkeyword=footcited]

\end{document}

Result:

enter image description here

share|improve this question

closed as too localized by Andrew Swann, mafp, barbara beeton, lockstep, Werner Jun 12 '13 at 21:01

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Removing the Russian language stuff (which won't compile on my machine) I get the correct behaviour with the extra options you suggest at the top of your question. However, you have to run xelatex on this a couple of extra times. –  Andrew Swann Jun 12 '13 at 19:35
    
@AndrewSwann: I posted no Russian, no biblatex-gost MWE with resetnumbers. Does it work on Your machine? –  Adobe Jun 12 '13 at 19:54
1  
Yes this version runs fine for me using xelatex, biber, xelatex, xelatex. Note that subsequently you need two runs of xelatex; after one, the numbering is wrong and the log file contains the warning Package biblatex Warning: Please rerun LaTeX., after that second run the number is again correct. –  Andrew Swann Jun 12 '13 at 20:13
    
@AndrewSwann: You right: I just have to debug my tex running script. Works for biblatex-gost as well. –  Adobe Jun 12 '13 at 20:20
    
In that case, I think we should close this as too localised. –  Andrew Swann Jun 12 '13 at 20:23

Browse other questions tagged or ask your own question.