Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm using the scrbook class. I don't like the way that my index entries are included as margin notes. How can I prevent the index entries from being shown in the margins? I consulted the KOMA-Script manual but was unable to find anything that addresses this issue.

Sample code follows:

\documentclass[letterpaper,openright,12pt,chapterprefix=true,index=totoc]{scrbook}
\usepackage[english]{babel}
\usepackage{makeidx,showidx}
\title{The Title}
\author{The Author}
\date{}
\makeindex
\begin{document}
\frontmatter
\pagenumbering{roman}
\tableofcontents
\chapter*{Preface}
\addcontentsline{toc}{chapter}{Preface}
Lorem ipsum dolor sit amet, consectetur adipiscing elit. 
\mainmatter
\pagenumbering{arabic}
\chapter{The Chapter Name}
\addcontentsline{toc}{chapter}{The Chapter Name}
Lorem ipsum dolor sit amet, consectetur adipiscing elit.
\index{Lorem ipsum!dolor sit amet}
Sed a tellus augue. Phasellus ut ultrices velit.
\index{Sed a tellus!augue}
\backmatter
\printindex
\end{document}
share|improve this question
1  
Welcome to TeX.SE. It is the \usepackage{showidx} that is placing the index entries in the margin, not the scrbook class. So removing the showidx from the list of packages will remove the margin notes for index enteries. –  Peter Grill Jun 19 '13 at 0:12
    
This solved the problem--newbie mistake. Thanks! However I don't see an option to accept this answer. –  Brent Jun 19 '13 at 0:37
    
Have posted it as an answer, you should now see the up arrow for voting and check mark for accepting. –  Peter Grill Jun 19 '13 at 1:35
add comment

closed as too localized by Werner, Heiko Oberdiek, mafp, Fran, Guido Jun 19 '13 at 3:20

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

It is the \usepackage{showidx} that is placing the index entries in the margin, not the scrbook class. So removing the showidx from the list of packages will remove the margin notes for index entries.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.