Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

In the following, I create a separate glossary that I do not want to have hyperlinked (in my actual document, the glossary without links will not be displayed).

The following MWE generates an error:

Unknown option 'nohypertypes' for package 'glossaries'

\documentclass{report}

\usepackage{hyperref}
\usepackage[nohypertypes={common}]{glossaries}

\newglossary{common}{cacr}{cacn}{Common Acronyms}
\newglossaryentry{unlinkedtest}{
    type={common},
    name={test glossary entry},
    description={should not be linked}}
\newglossaryentry{linkedtest}{
    name={test glossary entry},
    description={should be linked}}
\makeglossaries%

\begin{document}
    This should be linked: \gls{linkedtest}\par%
    This should not be linked: \gls{unlinkedtest}
    \printglossary[type=common]%
    \printglossary[type=main]%
\end{document}

The nohypertypes option is detailed as a new change in v3.04 and the log file shows glossaries v3.04 is being loaded. Without the nohypertypes option, the MWE works, except that both \gls are linked to their glossary entries.

share|improve this question

closed as too localized by lockstep, mafp, Heiko Oberdiek, Charles Stewart, barbara beeton Jun 22 '13 at 13:07

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

add comment

2 Answers 2

up vote 1 down vote accepted

This is a known bug of glossaries 3.04. It has been fixed in version 3.05. Please update that package.

share|improve this answer
    
How can I update it? In TeX Live Utility, I don't get the option to update anything - do I have to get MacTeX 2013? –  Chris Jun 22 '13 at 12:17
    
@Chris This depends on your system and distribution, I think this should help. –  mafp Jun 22 '13 at 12:23
    
So if I want to use the TeX Live Utility to manage the packages installed, it has to be the most up to date version, which is why my 2012 version no longer lists any available updates. 2013 update looks the easiest option. –  Chris Jun 22 '13 at 12:35
add comment

At least with 3.05 (I'm using TeX Live 2013) the option is 'nohypertypes' rather than 'nohyperlist'.

Good Luck, Herb Schulz

share|improve this answer
    
Oops copy/paste error in my MWE –  Chris Jun 22 '13 at 11:42
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.