Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I’ve just installed MacTeX 2013, which includes TeX Live 2013. This somehow breaks the Contextuals=(No)LineFinal feature from fontspec with Hoefler Text Italic.

It works as I expect with MacTeX 2012 (which I fortunately still have installed).

The following file is typeset with a swash on the final n with MacTeX 2013, but not with MacTeX 2012.

\documentclass{article}
\usepackage{fontspec}

\setmainfont [UprightFeatures={Contextuals=NoLineFinal}]{Hoefler Text Italic}
% One could use [ItalicFeatures={Contextuals=NoLineFinal}]{Hoefler Text}
% and add a \itshape or \textit to the document

\begin{document}

There should be no swash to this last n

\end{document}

Compiling aat-info.tex reports the same features with both version of MacTeX, and in both case, it reports Line Final Swashes as on.

Is it a new bug or was I unknowingly relying on an old, now fixed, one? In any case, how could I get the swashes to disappear again?


I’m still looking into the issue, and this is likely related.

With Apple Chancery, I can’t find a way to turn on Line Initial Swashes or Line Final swashes in MacTeX 2013. In MacTeX 2012, LineInitial triggers very often, including in the middle of a line. It seems to me it does the same thing as WordInitial.

In both MacTeX 2012 and 2013, WordInitial and WordFinal appear to work fine when turned on.

Once again, aat-info.tex reports the same features and defaults when run with MacTeX 2012 or 2013. However, MacTeX 2013 reports them in french (my system default) while MacTeX 2012 does it in english.

\documentclass{article}
\usepackage{fontspec}

\setmainfont {Apple Chancery}
% Explicitly turn on Word initial/final swashes
% \setmainfont [Contextuals={WordInitial, WordFinal}]{Apple Chancery}
% Explicitly turn on Line initial/final swashes - actually the default
% \setmainfont [Contextuals={LineInitial, LineFinal}]{Apple Chancery}
% Explicitly turn off Line initial/final swashes
% \setmainfont [Contextuals={NoLineInitial, NoLineFinal}]{Apple Chancery}

\begin{document}

% Examples courtesy of Apple
Rolling hills, Rolling\\
pines, Rolling thunder

Pears, pinapples, cherries\\
and so many grapes

I saw one in a box once

\end{document}

Next step, try pure XeTeX. Unfortunately, I don’t know much about it.

share|improve this question
    
I get AAT feature 'Contextuals=NoLineFinal' (8,7) not available in font 'Hoefler Text' –  egreg Jun 24 '13 at 23:15
    
They are only available for italics, [ItalicFeatures={Contextuals=NoLineFinal}]{Hoefler Text} or [UprightFeatures={Contextuals=NoLineFinal}]{Hoefler Text Italic}. –  Édouard Jun 24 '13 at 23:26
    
AAT feature 'Contextuals=NoLineFinal' (8,7) not available in font 'Hoefler Text/I'; however this might depend on the OS (I'm on 10.8.4). I don't get the swash anyway. –  egreg Jun 24 '13 at 23:29
    
I’m on 10.6.8. Not really reassuring for future compatibility... Oh, well, I’m trying to get rid of them anyway. –  Édouard Jun 24 '13 at 23:33
    
Actually, if I try it with TL 2012 I get errors. :( –  egreg Jun 24 '13 at 23:34
show 5 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.