Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm using BibDesk for mac (just a front-end for creating and maintaining a BibTex file) and BibLaTeX-mla. The problem I'm having is that as long as I'm setting BibLaTeX to style=mla, then the citation shows up in-line, but not in the actual bibliography. The hyperlink even works, but it just goes to below the other citation.

The LaTeX file is as follows:

\documentclass[12pt,letterpaper]{article}
\usepackage[parfill]{parskip}
\usepackage[american]{babel}
\usepackage{csquotes}
\usepackage{hyperref}
\usepackage[style=mla]{biblatex}
\usepackage{mla}
\defbibheading{bibliography}{\newpage\centering Works Cited}
\bibliography{Bibliography}
\begin{document}
\begin{mla}{Stephen}{Searles}{Professor's last name}{Class name}{\today}{Title}
Start typing paragraph 1 here
Continue the rest of the paper as normal \cite{Kauffman:2002kx}.
\begin{center}
\printbibliography
\end{center}
\end{mla}
\end{document}

And the related BibTex records:

@book{shepard2002act,
    Date-Added = {2011-02-25 12:48:03 -0800},
    Date-Modified = {2011-02-25 12:48:03 -0800},
    Editor = {Shepard, B. and Hayduk, R.},
    Isbn = {1859843565},
    Publisher = {Verso Books},
    Title = {From ACT UP to the WTO: Urban protest and community building in the era of globalization},
    Year = {2002}}

@inbook{Kauffman:2002kx,
    Author = {Kauffman, LA},
    Chapter = {A short history of radical renewal},
    Crossref = {shepard2002act},
    Date-Added = {2011-02-25 13:04:16 -0800},
    Date-Modified = {2011-02-25 13:04:56 -0800},
    Pages = {35-39}}

Am I doing something wrong here?

share|improve this question
    
Are you sure you're also running bibtex on the file? You need to do latex then bibtex then latex (twice) to get all the citations linked up. Are you getting any undefined reference warnings in your log? See also the answer to this question: Undefined citation warnings –  Alan Munn Feb 25 '11 at 23:42
    
Nope, no warnings like that in the log. And yes, I use a script to run all that stuff in the proper order. –  Stephen Searles Feb 25 '11 at 23:45
    
Well your example works fine for me. (Also on a Mac, although I don't think this should matter.) –  Alan Munn Feb 25 '11 at 23:48
1  
Actually, your specific example doesn't work: your bib items don't match the cite keys in your example document. But fixing that, things work. –  Alan Munn Feb 26 '11 at 0:00
    
How odd. I think I found a potential workaround anyway by tweaking the bibtex fields, still sort of figuring it out. Out of curiosity, in the bibliography that came up in your test, did the second and beyond lines have a hanging indentation? –  Stephen Searles Feb 26 '11 at 0:04
show 3 more comments

3 Answers

up vote 4 down vote accepted

Your database entries are reversed. Editing the example to read

@inbook{Kauffman:2002kx,
    Author = {Kauffman, LA},
    Chapter = {A short history of radical renewal},
    Crossref = {shepard2002act},
    Date-Added = {2011-02-25 13:04:16 -0800},
    Date-Modified = {2011-02-25 13:04:56 -0800},
    Pages = {35-39}}

@book{shepard2002act,
    Date-Added = {2011-02-25 12:48:03 -0800},
    Date-Modified = {2011-02-25 12:48:03 -0800},
    Editor = {Shepard, B. and Hayduk, R.},
    Isbn = {1859843565},
    Publisher = {Verso Books},
    Title = {From ACT UP to the WTO: Urban protest and community building in the era of globalization},
    Year = {2002}}

deals with the problem.

This is covered in the excellent Tame the BeaST, p. 26:

One other important remark is that cross-referenced entries must be defined after entries containing the corresponding crossref field. And you can’t embed cross-references, that is, you cannot crossref an entry that already contains a crossref.

share|improve this answer
1  
So this is a BiBDesk issue? In the Preferences -> Crossreferences you need to click the "Automatically sort for crossrefs when saving BiBTeX files". But even with the records in this order I don't get the citations. –  Alan Munn Feb 26 '11 at 10:51
    
@stephens I'm not sure why you accepted this answer, since it doesn't actually solve your problem, which is caused by a bug in the biblatex-mla style. (Even though Joseph's observation about cross-references is absolutely on target.) –  Alan Munn Feb 26 '11 at 21:49
add comment

There are two problems with your example. As Joseph pointed out, bibtex requires cross-referenced entries in the bib file to be defined after the entries with the crossref. To do this in BiBDesk, you need to set the Crossreferences preference to "Automatically sort for corssrefs when saving BiBTeX files." (It's also a good idea to set the 'Duplicate "Title" field to "Booktitle"' preference.)

The second problem is that your cross-referenced entry is of the wrong type: it should be @incollection instead of @inbook. Changing the entry type to @incollection produces the reference correctly with the mla bibliography style.

share|improve this answer
add comment

It's a matter of using @inbook and @book, rather than @incollection and @collection. Biblatex-mla doesn't define crossreferences for @inbook entries, only because of a design choice I made: in MLA-style papers, rarely (if ever) should one cite a particular chapter. Collections of essays are something different altogether, as your use here indicates.

I am planning on changing the behavior in future versions of biblatex-mla, as it's trivial to add and will avoid future confusion of this being a bug.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.