Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

When trying to compile any document containing the line:

\usepackage[brazilian]{babel}

I get the following error:

! Package babel Error: Unknow option `brazilian'. Either you misspelled it
(babel)                or the language definition file brazilian.ldf was not fo
und.

Additional info:

  • I get an analagous error when replacing brazilian by anything other than english.
  • I'm running texlive on Windows, so my way of managing packages is through tlmgr
  • Tried to uninstall and reinstall babel package and got nothing.
  • I sense something is wrong since babel is looking for the file "brazilian.ldf" but this is my output to tlmgr search --global --file "brazilian":
tlmgr.pl: package repository http://mirror.jmu.edu/pub/CTAN/systems/texlive/tlnet
biblatex:
        texmf-dist/tex/latex/biblatex/lbx/brazilian.lbx
biblatex-apa:
        texmf-dist/tex/latex/biblatex-apa/brazilian-apa.lbx
dvdcoll:
        texmf-dist/tex/latex/dvdcoll/dcl/brazilian.dcl
minitoc:
        texmf-dist/tex/latex/minitoc/brazilian.mld

So, no brazilian.ldf here...

UPDATE:

Looking at the comments and searching for portuges.ldf file, the following package install command solved the problem here:

tlmgr install babel-portuges

(ps: had to remove old .aux files)

share|improve this question
1  
Use brazil instead. –  Sigur Jun 26 '13 at 22:55
1  
What engine are you using to compile with? (pdfLaTeX? LuaLaTeX?) The brazilian option is a synonym of portuges which is why you won't find a brazilian.ldf. –  Alan Munn Jun 26 '13 at 23:02

2 Answers 2

If you look into babel.sty (version 2013/05/16 v3.9f), you will see the option declaration for brazilian:

\DeclareOption{brazil}{\bbl@load@language{portuges}}
\DeclareOption{brazilian}{\bbl@load@language{portuges}}

Thus the basic language definition file is portuges.ldf. It is often the case that a language can support several dialects and aliases.

The file portuges.ldf is part of package babel-portuges in TeX Live 2013. From tlpkg/texlive.tlpdb (TeX Live Package DataBase):

name babel-portuges
category Package
revision 30284
docfiles size=36
 texmf-dist/doc/generic/babel-portuges/portuges.pdf
srcfiles size=7
 texmf-dist/source/generic/babel-portuges/portuges.dtx
 texmf-dist/source/generic/babel-portuges/portuges.ins
runfiles size=2
 texmf-dist/tex/generic/babel-portuges/portuges.ldf

As option brazilian is known to babel (see the option declaration above), the file portuges.ldf is very likely not installed. After installing babel-portuges with tlmgr the problem should be solved.

share|improve this answer

If you don't have the language installed you can do it installing texlive-lang-portuguese.

Then the brazilian option should work.

share|improve this answer
    
I'm sorry, but how exactly can I install it? It's through tlmgr (it says there is no such package)? –  BabelError Jun 27 '13 at 1:31
    
@BabelError: That's probably a debian/ubuntu package. –  Martin Schröder Jun 27 '13 at 19:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.