Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I know this question has been asked before but the solutions given do not apply/work for My 10.8 system for one reason or another. I am attempting to install a style file. I place it in the subdirectory in the texlive installation and run sudo texhash. Yet, latex says, "No can do; cannot find the *.sty file." What about the suggestions to place the file in directory in ~/Library/texmf? Those proposed solutions expect a different directory structure beneath texmf than I have. I really have no idea where to put this thing so My Aquamacs.app can find it when creating a *.pdf file.

Addendum: I notice this question has been marked with the text "marked as duplicate by Martin Schröder, Werner, Sigur, cgnieder, mafp Jun 27 at 20:56 This question has been asked before and already has an answer. If those answers do not fully address your question, please edit this question to explain how it is different or ask a new question." To the "[i]f those answers do not fully address your question, please edit this question to explain how it is different" part, I did explain that aspect when I said "I know this question has been asked before but the solutions given do not apply/work for My 10.8 system for one reason or another." Please be more thoughtful in what You mark as "duplicate" before doing so; what looks like from My perspective to be unjustified marking like this seems to be happening with increasing frequency on StackExchange and, as such, diminishes the usefulness of the site. Meanwhile, I ask any Moderator seeing this to remove the "duplicate" marking.

Addendum #2: Also, the "This is where it was already answered" link is something I tried first. As noted, this approach did not work.

share|improve this question
2  
In your ~/Library/texmf you need to create enough directory structure for TeX to find the file properly. For a .sty file, you would need ~/Library/texmf/tex/latex/<your-style.sty>. Remember that ~/Library is hidden by default, but you can get to it via the Go menu if you hold down the Option key. You don't need to run texhash for such files. –  Alan Munn Jun 27 '13 at 1:12
1  
Check which versions of texhash and latex are running with the which command. Also, check the output of texhash to see if is parsing (the parent of) the directory you put your .sty in. If it is parsed, check that kpsewhere finds it. –  Xavier Jun 27 '13 at 1:36
1  
@xuinkrbin You have edited your question but you haven't given us any more information to be able to diagnose what your problem is. For example, you haven't responded to my question in the comments or Xavier's comment. –  Alan Munn Jun 30 '13 at 23:59
1  
@AlanMunn: Success, thank You. I only wish You could list this idea as an answer so I could "accept" it. –  xuinkrbin. Jul 1 '13 at 0:50
1  
I'm glad it worked, that's all. We really do try to be helpful around here. :) –  Alan Munn Jul 1 '13 at 0:58

1 Answer 1

up vote 8 down vote accepted

The following answer comes from decoding the comments. The simple fact is that most TeX distribution problems on the Mac come from not having the MacTeX distribution installed.

In your case, you had the MacPorts distribution, which places everything in a /opt directory. However, most standard TeX editors for the Mac will assume that you have MacTeX installed. MacTeX installs a control panel which allows you to easily keep multiple TeX distributions on your machine and easily switch between this. Basically it does this by creating a series of symbolic links to the current distribution so that on the surface all TeX binaries are located in /usr/texbin.

Non-MacTeX distributions do not use this system, which is why Acquamacs couldn't find the TeX binaries. The MacTeX distribution also sets the local texmf folder to ~/Library/texmf, but MacPorts presumably doesn't assume this either.

The best solution to this problem is to remove the MacPorts distribution and install MacTeX instead.

Most Mac users here will assume you have this distribution setup, and most of the advice on the site also assumes that setup.

share|improve this answer
    
Thanks. I have found assumptions to be dangerous, though. ;-) –  xuinkrbin. Jul 1 '13 at 23:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.