Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

This will be my last ConTeXt question for a little while...I've set up

\setuptabulate[indenting=yes,margin=40pt]

This works only to the extent that the table cells are indented appropriately - but the horizontal rules stretch all the way to the left margin. How do I set up a table to be indented properly - including its horizontal lines?

Here's a minimal example (without changing the table margin):

\setupindenting[20pt, yes]
\setuptabulate[indenting=yes]

\starttext
The following is a table for which the horizontal lines are wrong.
\starttabulate[|c|c|]
\HL
\NC Col 1 \NC Col 2 \NC\NR
\HL
\NC 1 \NC 2 \AR
\NC 3 \NC 3 \AR
\HL
\stoptabulate
See what I mean?

\stoptext

If you bung this through texexec you'll see that the lines of text are indented, but that the horizontal lines in the table aren't.

Thanks!

share|improve this question
1  
Please add a minimal example that illustrates your problem. –  TH. Feb 27 '11 at 6:18

1 Answer 1

The correct answer would be: use \startnarrower ... \stopnarrower, but that does not work either. This setup produces the desired output (but I will point Hans to this example):

\setupindenting[20pt, yes]
\setupnarrower [left=20pt]

\starttext
The following is a table for which the horizontal lines are wrong. Bla
\startnarrower[left]
\startframedtext[frame=off,offset=overlay]
\starttabulate[|c|c|]
\HL
\NC Col 1 \NC Col 2 \NC\NR
\HL
\NC 1 \NC 2 \AR
\NC 3 \NC 3 \AR
\HL
\stoptabulate
\stopframedtext
\stopnarrower
See what I mean?

\stoptext
share|improve this answer
    
Tried that - made absolutely no difference. Do I have to set up first with setupnarrower? Actually, if I include the line setupnarrower[middle=6cm] in the preamble, and then use \startnarrower ... \stopnarrower the table is positioned in the middle - but the lines still extend all the way to the left margin. –  Alasdair Feb 28 '11 at 9:00
    
Arrgh - this is a right royal pain. I simply cannot get my simple table, including its horizontal and vertical rules, moved away from the left margin. I've tried innumerable combinations of settings, with both table and tabulate, all to no avail. This is a very simple table... but its positioning is giving me grief! –  Alasdair Feb 28 '11 at 10:00
    
answer adjusted –  Taco Hoekwater Feb 28 '11 at 10:13
    
Woo hoo - that works perfectly! Thank you very much. I wonder why it's so complicated, though? I can move other things around very easily just by playing with margins: itemized lists, formulas etc - why not tables? –  Alasdair Feb 28 '11 at 11:52
    
@Alasdair: the same should have worked for tables, but it appears broken/bugged. That's why I said I would alert Hans on this problem. –  Taco Hoekwater Feb 28 '11 at 12:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.