Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am having a problem with my references, the error message is

Bibliography not compatible with author-year citations.

I have stripped down all tex and references files however I still have the same problem.

I have tried the following:

  • Delete all the temp file. I am using WinEdt8
  • I have year in my reference
  • Using \citet instead of \cite
  • Try \usepackage[square,sort,comma,numbers]{natbib}

It will be much help you can help point out where did I went wrong :(

Here are the content of the files

.tex file:

\documentclass[english]{article}
\usepackage[T1]{fontenc}
\usepackage[latin9]{inputenc}
\usepackage{babel}
\usepackage[authoryear]{natbib}
\begin{document}
Text here

\citet{Ioannou2001}

\bibliographystyle{IEEEtran}
\bibliography{reference}

\end{document}

.bib file (with only one record)

    @ARTICLE{Ioannou2001,
      author = {Ioannou, G and Kritikos, M and Prastacos, G},
      title = {A greedy look-ahead heuristic for the vehicle routing problem with
  time windows},
      journal = {J Oper Res Soc},
      year = {2001},
      volume = {52},
      pages = {523--537},
      number = {5},
      month = apr,
      __markedentry = {[duongh:6]},
      issn = {0160-5682},
      owner = {d},
      publisher = {Palgrave Publishers Ltd},
      timestamp = {2013.03.29},
      url = {http://dx.doi.org/10.1057/palgrave.jors.2601113}
    }
share|improve this question
5  
The problem is with the use of IEEEtrans style which produces \bibitems that are not compatible with the natbib style. In addition IEEEtrans is a numeric citation format. –  Guido Jul 1 '13 at 2:04

2 Answers 2

The bibliography style IEEtran was developed for the class IEEEtran. All the settings are done for the Institute of Electrical and Electronics Engineers. By default there is no compatibility for natbib. However the authors of IEEtran provides an extra bibliography style which is compatible with natbib and provides the same formatting as IEEtran. This style is called IEEEtranN. As the default style the style IEEEtranN is a numerical style and so you need the option numbers for the package natbib. The example below uses IEEEtranN and results to

enter image description here

\RequirePackage{filecontents}
\begin{filecontents}{reference.bib}
@ARTICLE{Ioannou2001,
      author = {Ioannou, G and Kritikos, M and Prastacos, G},
      title = {A greedy look-ahead heuristic for the vehicle routing problem with time windows},
      journal = {J Oper Res Soc},
      year = {2001},
      volume = {52},
      pages = {523--537},
      number = {5},
      month = apr,
      __markedentry = {[duongh:6]},
      issn = {0160-5682},
      owner = {d},
      publisher = {Palgrave Publishers Ltd},
      timestamp = {2013.03.29},
      url = {http://dx.doi.org/10.1057/palgrave.jors.2601113}
    }
\end{filecontents}
\documentclass[english]{article}
\usepackage[T1]{fontenc}
\usepackage[latin9]{inputenc}
\usepackage{babel}
\usepackage[numbers]{natbib}
\begin{document}
Text here

\citet{Ioannou2001}

\bibliographystyle{IEEEtranN}
\bibliography{reference}

\end{document}
share|improve this answer
    
Hi, is there something similar for amsalpha? –  BlackAdder Jul 18 '13 at 13:07
    
@yanbo: ams is really special. I don't know any supporting by ams. Maybe you can use alphadin or plainnat –  Marco Daniel Jul 18 '13 at 17:14

I would recommend you switch to biblatex with biber as backend. Load biblatex

    \usepackage[%
        backend=biber,
        style=ieee,
        natbib=true,
        backref=false,
        backrefstyle=all+,
        hyperref=true,
    ]{biblatex}

Load your .bibfile

\addbibresource{BIBFILENAME} % enter with .bib extension

Both in your preamble.

Then print the bibliography where you want it using

\nocite{*} 

\printbibliography

\nocite{*} loads all the references in your .bib file.

share|improve this answer
    
\addbibresource requires the extension bib. –  Marco Daniel Jul 6 '13 at 11:11
    
My bad, changed it –  altabq Jul 8 '13 at 12:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.