Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.
\documentclass{beamer}
%\documentclass{article}

\usepackage{pstricks}

\usepackage{tikz}
\usetikzlibrary{chains}

\begin{document}
\begin{frame}{}
    \begin{tikzpicture}[start chain]
        \node[on chain] {A};
        \node[on chain,join={with chain-1 by {draw opacity=0}}] {B};
        \node[on chain,join={with chain-2 by {draw opacity=1}}] {C};
    \end{tikzpicture}
\end{frame}
\end{document}

which produces A-B-C. If I comment out \usepackage{pstricks} or use the article document class, then it produces A B-C, the correct result. Why is that and how can I use pstricks together with tikz and beamer in this case?

Edit: I use pdflatex.

share|improve this question
    
Which engine do you use to compile your document? –  Daniel Jul 1 '13 at 11:17
1  
With latex->dvips->ps2pdf, the result is correct. –  Paul Gaborit Jul 1 '13 at 11:18
    
I use pdflatex. –  neo Jul 1 '13 at 11:19
    
You cannot use pstricks from pdflatex –  JLDiaz Jul 1 '13 at 12:08
    
JLDiaz: Sure, with -shell-escape and \usepackage{auto-pst-pdf}. But my problem also occurs without this, so I didn't include it. –  neo Jul 1 '13 at 12:11

1 Answer 1

run it with xelatex instead of pdflatex. Then you also do not need the package auto-pst-pdf. However, I suppose a problem with beamers opacity settings.

share|improve this answer
    
xelatex takes 1min 6s to compile my slides. Then I rather use latex->dvips->ps2pdf which takes 9s. –  neo Jul 1 '13 at 12:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.