Sign up ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

My miktex (32 Bit) 2.9 installation (on windows 7, 64 Bit) doesn't update (GUI and console). I recognized the problem first on 2013-07-01. It seems to be caused by the package miktex-arctrl-bin-2.9 as the following lines from an elevated shell show.

C:\WINDOWS\system32>mpm --admin --update-db --verbose --install=miktex-arctrl-bin-2.9
677286 bytes, 2449.67 KB/Sec
updating package definition directory ("C:\Program Files (x86)\MiKTeX 2.9\tpm\packages")...
installed 136 package definition files
visiting repository
repository type: remote package repository
loading lightweight database...
134749 bytes, 1356.61 KB/Sec
starting package maintenance...
installation directory: "C:\Program Files (x86)\MiKTeX 2.9"
package repository:
lightweight database digest: 348d5562d8a8cb8e92530ca19eba0eb1
going to download 21784 bytes
going to install 6 file(s) (1 package(s))
21818 bytes, 213.07 KB/Sec
visiting repository
repository type: remote package repository
loading lightweight database...
134749 bytes, 1144.27 KB/Sec
lightweight database digest: 348d5562d8a8cb8e92530ca19eba0eb1
mpm: The operation could not be completed because the following file failed verification:
mpm: C:\Users\EBELIN~1\AppData\Local\Temp\mikEC80.tmp

I already tried to remove the (earlier existing but outdated) package miktex-arctrl-bin-2.9 but update and install fails. Cleaning the Temp storage directory and checking for file permissions there (temp) and in the install folder doesn't help.
Is there a solution without new installation?

Changing the repository to ...uni-erlangen... did not help - it results in the following screenshot: Screenshot after using uni-erlangen-erpo

share|improve this question
If the package is defective on the server a new installation would probably not help. But I made an update on another PC two days ago and had no problems. Did you try another repository? – Ulrike Fischer Jul 2 '13 at 7:43
Hi @UlrikeFischer, thank you for the idea. I did - without success. I'll post a screenshot in the question - showing an initex-error after switching to the uni-erlangen-repo. – Bastian Ebeling Jul 2 '13 at 10:59

1 Answer 1

Inspired by @UlrikeFischer, I tried around with changing the repository.

Via the GUI I got no chance - but running mpm from the console five times always with other errors (like timeout and file verifications errors) it finally went fine. Thanks.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.