Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Hi I can compile my latex document using pdflatex -synctex=1 -interaction=nonstopmode -shell-escape Masterthesis.tex

When I hit the quick compile button in textmaker however nothing happens. I noticed that the log in the texmaker log window shows the log I created when I compiled via the command line. Instead of compiling it shows me the old log file (I can tell it because the log shows when the command was issued, and its old).

In the settings the quick compile comand is set as follows: pdflatex -synctex=1 -interaction=nonstopmode -shell-escape %.tex

In addition if I remove the files that were created during build and then hit the quick compile button, I get a "Could not start command" error.

What could be wrong?

This is the log file: http://pastebin.com/eA2w5YTT

share|improve this question
1  
Welcome to TeX.SX! –  Papiro Jul 2 '13 at 18:01
    
I got this now and again, so finally installed rubber and configured QuickBuild to work with it. –  Forkrul Assail Jul 2 '13 at 18:35
1  
Open TeXmaker-->Options-->Configure TeXmaker-->QuickBuild--> IS pdflatex+viewpdf Checked on assuming bibtex run is not required ? TeXmaker is only IDE May be somewhat like a car without engine(pdflatex): Configuring TeXmaker for the right engine is key part –  texenthusiast Jul 3 '13 at 0:42
    
@texenthusiast yes it's checked. i worked with texmaker on ubuntu 12.04 before and it worked like a charm. now i'm on ubuntu 13.04 with gnome3. don't know if it has something to do with it –  Dominik Jul 3 '13 at 7:40
1  
i added the full path to the pdflatex command in the settings and now the quick compile command works (/usr/local/texlive/2013/bin/x86_64-linux/pdflatex -synctex=1 -interaction=nonstopmode -shell-escape %.tex) Although i'm wondering why it's working in the shell and not in texmaker? I added the path to latex in my .bashrc as export PATH="/usr/local/texlive/2013/bin/x86_64-linux:$PATH". Is that the wrong place? –  Dominik Jul 3 '13 at 8:13
show 1 more comment

1 Answer

up vote 1 down vote accepted

i now found the problem. i was exporting the path to texlive in my ~/.bashrc. This worked for my shell but apparently not for texmaker. I now export the path in ~/.profile and it works in shell and in texmaker (after restarting) (Note: I'm on ubuntu)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.