Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I want to externalize images using the commands:

\usepgfplotslibrary{external}
\tikzexternalize

The PGFPlots Manual says to use pdflatex -shell-escape <filename>. I'm assuming I should type this into the command line, but nothing is happening when I do. I need to do something similar to use GNUPlots, which is also not working for me.

My test file's name is abcd.

Update: I also tried changing \tikzexternalize to \tikzexternalize[shell escape=-enable-write18] and wrote pdflatex enable-write18 abcd.tex into the command line. The result was identical.

I'm using Windows 8 and I am not very computer savvy.

At the end, you'll find a series of images of what I am doing.

Hopefully, once this is figured out, I will be able to use GNUPlots as well...


MWE from PGFPlots Manual, which does not work at all...even minimally...:

\documentclass{article}

\usepackage{pgfplots}

\usepgfplotslibrary{external}
\tikzexternalize

\begin{document}
\begin{figure}
    \begin{tikzpicture}
        \begin{axis}
            \addplot {x^2};
        \end{axis}
    \end{tikzpicture}
    \caption{Our first external graphics example}
\end{figure}
\begin{figure}
    \begin{tikzpicture}
        \begin{axis}
            \addplot {x^3};
        \end{axis}
    \end{tikzpicture}
    \caption{A second graphics}
\end{figure}
\end{document}

  1. Compiling without typing anything into the command line, I get the error from the first picture (pasted into notepad to increase font size).
  2. Next, I go to the command line and type this and get a dialogue box...and nothing more happens with the command line. In fact, I can't type anything more into it.
  3. Last, I compile the my file abcd again in TeXworks and get the same error from Step 1.

enter image description here enter image description here

share|improve this question

closed as off-topic by Joseph Wright♦ Aug 23 '13 at 10:24

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center." – Joseph Wright
If this question can be reworded to fit the rules in the help center, please edit the question.

    
regarding 2.: did you install the missing package? regarding 3.: in Texworks you somehow must configure the command which is run when compiling. Here you also need to put in the -shell-escape –  bene Jul 5 '13 at 6:41
    
I clicked "Install", which I assume installs the missing package. About #3, what do you mean by "here you also need to put in the -shell-escape"? Where is "here"? Where in TeXworks do I put it? In the preamble? In Settings>Typsetting>Something? Can you please be more specific. All the manuals I've read say, "Then you put in -shell-escape there and it should work, but nobody seems to say what "there" refers to. –  JDG Jul 5 '13 at 6:52
1  
do you have administrator rights? If not, that could be the problem why the package is not being installed. "Here" does mean in Texworks. I don't use Texworks, but somewhere in the options, there should be a possibility to specify how the compilation is being done. There, you should insert the option. I for example use Texstudio and there you can go to Options > Configure Texstudio > Commands where you find the command for compiling. For me it is "pdflatex.exe -synctex=1 -shell-escape -interaction=nonstopmode %.tex" but for Texworks, the syntax could be different (especially with the %-sign) –  bene Jul 5 '13 at 8:41
    
I double-checked the tex files and I do already have the required file, which is dehypth exptl, which is a package concerning the special hyphenation of German words. I'm not sure why the package is necessary or why I would need to install it when I already have it. .........I will get back to you about configuring TeXworks compiling. I'm going to try it right now. –  JDG Jul 5 '13 at 8:51
    
Also, I do have system administration privileges. –  JDG Jul 5 '13 at 9:01