Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have downloaded xcolor.ins and xcolor.dtx from

http://kern.heimat.eu/tex/xcolor.html

These two files are in the same folder.

When I run the .ins file I get the error message Log file not found. The .ins file is a simple script added below.

\def\batchfile{xcolor.ins}

\input docstrip.tex

\askforoverwritefalse

\generate{\file{xcolor.lox}{\from{xcolor.dtx}{extract}}}

\batchinput{xcolor.lox}

\endbatchfile

Does anyone know what is wrong?

share|improve this question
    
You have to download the file xcolor200.zip, extract it and then follow the instructions in the README –  Red Jul 8 '13 at 16:08
    
Yes the README only tells to extract the files from the .dtx file and that should be what the .ins file does I believe when looking at the code. Maybe I have missed something –  Patrik Ek Jul 8 '13 at 16:11
1  
Are you using TeXmaker? I think this might be common problem with that editor. Perhaps run it from the command line: latex xcolor.ins. –  Werner Jul 8 '13 at 16:12
    
ok this may seem really basic. But how should I do to run it from the command line. I use TeXmaker so it is most likely that problem I have. However I am not sure how to use the command line in TeXmaker. I have tried to run it from the command Prompt but it only says file is not found. –  Patrik Ek Jul 8 '13 at 16:33
    
ok it seemed to work when I ran it in the command prompt thanks for all –  Patrik Ek Jul 8 '13 at 16:40

2 Answers 2

TeXmaker has some known issues in this regard. However, in this instance, you don't need to run the file xcolor.ins from within TeXmaker; a command-line approach is sufficient.

latex xcolor.ins
share|improve this answer
    
Usually a default configuration(targetting beginners who use mostly .tex file) in TeXmaker has latex -synctex=1 -interaction=nonstopmode %.tex expecting a .tex file as input to latex engine hence .ins is not recognised. Your guess with IDE was right. It is not a bug/issue (may be potential feature request) with TeXmaker in my view but can be customized Using User Command option. –  texenthusiast Jul 9 '13 at 4:33

Method :1 Using User Command in TeXmaker to run .ins file in TeXmaker

  • TeXmaker is default configured for normal users to run .tex files

    latex -synctex=1 -interaction=nonstopmode %.tex

  • Inorder to make TeXmaker run .ins extension files add an User Command Name latex-ins-run

    latex %.ins as shown in screenshots below

Step 1: Locating the User Command

enter image description here

Step 2: Defining User Command Name as latex-ins-run

enter image description here

Step 3: Executing latex-ins-run from a list of options

enter image description here

Finally once you press latex-ins-run command xcolor.ins is compiled with latex

enter image description here

Method :2 Running Terminal/Commandline in TeXmaker to get the .sty

  • TeXmaker--> File menu-->Tools--> Open Terminal

  • At Terminal/Commandline latex xcolor.ins

enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.