Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Okay I installed texlive 2012, just by following the guides from http://www.tug.org/texlive/.

Now when I downloadend, compiled and installed ipe7, the latest version. Now when I try something, draw/text etc, ipe tells me that it can't find pdflatex. Now I guessed that since I installed it from tug.org and not by a ubuntu package that it is now installed underneath a different directory. Pdflatex is located in the folder /usr/local/texlive/2012/bin/x86_64-linux/

Now I found in the manual that you can use the command flag IPELATEXDIR to point to a different location where pdflatex is located. So I started ipe --IPELATEXDIR=/usr/local/texlive/2012/bin/x86_64-linux/ but it still tells me that it can't find pdflatex?

I tried to find a log file in ~/.ipe/ but only the latex file is located there.

Does anybody got any clue?

share|improve this question
1  
Does pdflatex compiling normally? Did you insert the texlive folder in you $PATH variable? What is the result of echo $PATH on the terminal? –  Sigur Jul 8 '13 at 22:25
    
Oh no that I didn't do. I have my own custom command for compiling latex files which makes calls then pdflatex by just /dir/../dir/pdflatex. I will try to add the folder to $PATH variable. Thanks for the hint, hopefully this will solve the problem. –  WG- Jul 8 '13 at 22:31
    
Here is my $PATH variable: /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/lo‌​cal/texlive/2011/bin/i386-linux/ –  Sigur Jul 8 '13 at 22:33
    
Hmmm no it still says it can't find pdflatex. My $PATH variable is now PATH=/usr/local/texlive/2012/bin/x86_64-linux/:/usr/lib/lightdm/lightdm:/usr/lo‌​cal/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games –  WG- Jul 8 '13 at 22:41
1  
From the manual I get that IPELATEXDIR is an environment variable, not a command line option. So setting export IPELATEXDIR=/usr/local/texlive/2012/bin/x86_64-linux in your .bashrc might be the solution (with 2013, when you install the new TeX Live). –  egreg Jul 9 '13 at 11:26
show 8 more comments

1 Answer

up vote 3 down vote accepted

IPELATEXDIR is an environment variable, not a command line option.

So either you call the program as

IPELATEXDIR=/usr/local/texlive/2012/bin/x86_64-linux ipe

or, better, you set

export IPELATEXDIR=/usr/local/texlive/2012/bin/x86_64-linux

in your .bashrc file (or .profile or whatever you prefer).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.