Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I've recently switched to windows from linux and I'm having trouble getting my custom beamer style files to compile correctly. I have them in ~/texmf/tex/latex/local currently. There are other style files in there that are working correctly so the directory is on the right tex path, and when I copy the style files into the same directory as the code they also work.

Does beamer use a different path ? I ran texhash.exe, is there a separate command to set the beamer path?

share|improve this question
1  
Are you using TeX Live or MikTeX? In general, Windows don't have the flexibility of maintaining your own distro so better don't touch anything. Rather use the package install wizards (oxymoron). –  percusse Jul 9 '13 at 19:18
    
Well for TeXLive all the beamer style files are in C:\texlive\2013\texmf-dist\tex\latex, but they should be found in the folder you created, so this is strange. You could try to put it in the explicit beamer folder in the above directory. Here: C:\texlive\2013\texmf-dist\tex\latex\beamer\themes\theme –  option_select Jul 9 '13 at 19:27
    
I'm using MikTeX 2.9. The beamer files are in C:\Program Files\MiKTeX 2.9\tex\latex\beamer\* and they all seem to be loading fine, just not my custom files. –  slammaster Jul 9 '13 at 20:21
    
You should not modify your MikTeX folder. Put your custom style files either in the working directory or somewhere TeX can find them. –  percusse Jul 9 '13 at 20:42
1  
...somewhere TeX can find them: Which is the best directory to keep .sty files where MiKTeX can find them? for eg: C:\localtexfiles\tex\latex\misc\custombeamer.sty and Refresh FNDB –  texenthusiast Jul 9 '13 at 21:06

1 Answer 1

up vote 0 down vote accepted

My bad. It turns out that texpath.exe wasn't updating the path correctly. For anyone that wants to fix this, after adding files to your ~/texmf/tex/latex/local directory (or whatever you're using) you need to refresh the MikTeX path. Go to MiKTeX 2.X > Maintenance (Admin) > Settings (Admin) (or without the (Admin), if that is not in your menus), "General" tab > "Refresh FNDB".

I got the answer from this site

share|improve this answer
    
In the manual of MiKTeX you will find this information (updating FBDN is needed) too ... May I ask how it turns out? perhaps that is interesting for other users? Or has it only to do with your used special beamter theme (it seems so, looking on your cited site)? –  Kurt Aug 4 '13 at 13:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.