Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am trying to make a glossary in an amsart document using TeXstudio but the glossary will not print. I've downloaded xindy, arara, and perl and have tried to use all of them, but to no avail. Any thoughts?

A Minimal example containing all of the relevant packages, etc.:

% arara: pdflatex
% arara: makeglossaries
% arara: pdflatex    
% arara: pdflatex
\documentclass[9pt]{amsart}
\usepackage{amsmath, amssymb, amsthm}
\usepackage[toc,page]{appendix}
\usepackage{url}
\usepackage{hyperref}
\usepackage[xindy]{glossaries}
\makeglossaries

\newglossaryentry{def1}{name={first definition},description={description1}}
\newglossaryentry{def2}{name={second definition},description={description2}}

\begin{document}
\section{Preliminaries}

This is \gls{def1} and this is \gls{def2}.

\printglossaries
 \end{document}
share|improve this question
    
Can you provide a minimal example? Have you remembered to use \makeglossaries in your preamble? Has a glossaries log file (.glg) been created? If it has, does it have any error messages in it? –  Nicola Talbot Jul 10 '13 at 18:26
    
Welcome to TeX.SX! You can have a look on our starter guide to familiarize yourself further with our format. –  Claudio Fiandrino Jul 10 '13 at 18:30
    
Also a .glg file has not been created... a .glo one has... –  user33486 Jul 10 '13 at 19:02
    
I get a glossary as expected. –  egreg Jul 10 '13 at 19:20
    
I don't have xindy, so I've removed [xindy] from the call to the glossaries package. And I, too, get the expected result. –  karlkoeller Jul 10 '13 at 19:24

1 Answer 1

In order to use arara with xindy you need to have the xindy rule installed. This is a file called xindy.yaml. The following is adapted from Paulo Cereda's texindy.yaml rule:

!config
# Xindy rule for arara
# requires arara 3.0+
identifier: xindy
name: Xindy
command: <arara> xindy @{german} @{language} @{codepage} @{module} @{input} @{options} "@{getBasename(file)}.idx"
arguments:
- identifier: german
  flag: <arara> @{isTrue(parameters.german,"-g")}
- identifier: language
  flag: <arara> -L @{parameters.language}
- identifier: codepage
  flag: <arara> -C @{parameters.codepage}
- identifier: module
  flag: <arara> -M @{parameters.module}
- identifier: input
  flag: <arara> -I @{parameters.input}
- identifier: options
  flag: <arara> @{parameters.options}

This file should go in the rules directory of arara's installation directory. On Windows, this is probably something like C:\Program Files\arara, but if you installed it via TeX Live, it might have gone in TeX Live's scripts subdirectory.

Edit: Actually, I realise this doesn't answer your question, as you're directly invoking makeglossaries rather than xindy. Check to make sure you actually have xindy installed. Another alternative is to try using makeglossariesgui which has diagnostic tools which might help you track the problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.