Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I've got a problem when editing a TeX file. I've changed \normalsize to 20pt by

\newcommand{\mysize}{\fontsize{20pt}{\baselinestretch}\selectfont}
\renewcommand{\normalsize}{\mysize}

and this caused the font size of page number in the chapter page can not be modified when using the fancy macro package. So can anyone help me?

Then (after reading the now deleted comments) I've used the following command

\documentclass[fontsize=20]{scrbook}

but the problem is still can not be solved.

share|improve this question
    
I guess that you should read in the fancyhdr manual the part about "redefining plain style". –  Ulrike Fischer Mar 1 '11 at 12:58
add comment

1 Answer 1

Extending my comment: Simply redefining \normalsize is not a good idea. There are further lengths which are chosen matching the base font size, specifically regarding vertical spacing. For example, if you look into the file book.clo, which contains class options for book, you can see it.

For a consistent change I recommend changing the document class.

  • the extsizes bundle provides classes similar to standard classes offering a base font size from 9pt to 20pt.

  • memoir can also be used with 20pt and more. In this regard, the option extrafontsizes may be useful. For very high font size a scalable font should be used.

  • KOMA-Script classes, such as scrartcl, scrbook and scrreprt support arbitrary base font sizes. You could even user other units than pt to specify the size.

Since KOMA-Script classes offer many more features, this would be my choice.

The further way depends on how your're producing the footer. On chapter starting pages, the page style is plain.

  • With default page styles the base font size should be used, so there's no problem.

  • With fancyhdr, you could simply add \small, \normalsize or any orher font size command to the beginning of your header and footer macros. If necessary, use \fancypagestyle{plain}{\fancyhf{}\cfoot{\small\thepage}}, like Ulrike already said in comments to question and to this answer.

  • With a KOMA-Script class, I recommend to use scrpage2 instead of fancyhdr. Since it belongs to the KOMA-Script bundle, it's very well integrated with the classes. That should also solve the problem. If necessary, use a font size command such as \small, \tiny or just \normalsize within header and footer commands. Note: for plain pages do it also within the optional argument, such as \cfoot[\tiny\thepage]{\tiny\thepage}. scrpage2 is explained in the KOMA-Script manual.

With KOMA-Script there are more and even easier possible solutions. You could use \addtokomafont or \setkomafont for specifying the font size. For example:

\addtokomafont{pagenumber}{\tiny}

Further font option names, which you might use in this regard: pagehead, pageheadfoot, pagefoot.

share|improve this answer
    
Yes, the scrpage2 is involved in my tex file, and I used the command: lefoot, refoot,rofoot, lofoot which used \tiny command to control font size of foot number, but the page number in chapter page's is not changed, is actually 20pt. –  user3908 Mar 1 '11 at 15:28
    
@buddy.qin: try my last advice and example using \addtokomafont. –  Stefan Kottwitz Mar 1 '11 at 16:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.