TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I try to compile the .tex-file, I get an error, telling me that the pdflatex.ini is missing in \tex\config\pdflatex.ini.
I went looking into the directory - and the file is there. But TeXWorks tells me:

This is pdfTeX, Version 3.1415926-1.40.11 (MiKTeX 2.9)
miktex-pdftex.exe: The memory dump file could not be found.
miktex-pdftex.exe: Data: pdflatex.fmt

I also looked for miktex-pdftex.exe, and I found it in the bin.
Problem is, somehow I didn't got a new logfile.

I would appreciate some help with this. Thanks!

share|improve this question

closed as too localized by Stefan Kottwitz Sep 6 '11 at 15:42

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

\tex\config\pdflatex.ini is a curious location. There should exists two pdflatex.ini (with different contents). One in miktex\config and the other (needed for the format generation) in \tex\latex\config. Try to build the pdflatex format in miktex settings. – Ulrike Fischer Mar 1 '11 at 11:54
yes, I'm sorry I forgot the "\latex" The file is also in miktex\config. – MiKa Mar 1 '11 at 13:41
It is not "the" file. They are both very different (open them in a editor and look) and are used for different purposes. So don't confuse them. Did you try to build the pdflatex format? – Ulrike Fischer Mar 1 '11 at 13:52
yes I did. I already compiled it at home with TeXnicCenter. Yes, I noticed that they are different, and I didn't copy them etc. They where already there after I installed MiKTeX. – MiKa Mar 1 '11 at 14:16
"yes I did. I already compiled it at home with TeXnicCenter." Well you can't compile the format with TeXnicCenter. So you probably don't have a clue what the format is. Go to miktex-settings to the format tab. Click on the pdflatex entry and then on "build". – Ulrike Fischer Mar 1 '11 at 14:45

Have you tried renewing MiKTeX's File Name Database?

You can find it in Start > Programs > MiKTeX > Settings or run command mo in command shell. Then click Refresh FNDB.

share|improve this answer
Thank you very much, that is a good idea, but sadly doesn't solves my problem. – MiKa Mar 1 '11 at 13:40
up vote 1 down vote accepted

I reinstalled MiKTeX and it solved the problem. Thank you very much for helbping me!

share|improve this answer
Could you please accept this answer (using the tick mark below the voting buttons) so that it is removed from the list of "unanswered questions". Thank you. – Martin Scharrer Mar 2 '11 at 10:30
I wasn't able to do so. The yellow box tells me that I have to wait 21 more hours until I can accept it. Otherwise I would have already done so. :-( I'm sorry. – MiKa Mar 2 '11 at 12:34

Not the answer you're looking for? Browse other questions tagged or ask your own question.