Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I've a bit of a weird question. I would like to put an equation in the section title (I'm using book) but LaTex spits out the following error:

    [31] [32]Making bbold25.tfm from C:\Users\unknown\AppData\Local\MiKTeX\2.9\fonts\source\jknappen\sauter\bbold25.mf...
Running miktex-mf.exe...
This is METAFONT, Version 2.718281 (MiKTeX 2.9)

(C:\Users\unknown\AppData\Local\MiKTeX\2.9\fonts\source\jknappen\sauter\bbold25.

mf

! I can't find file `b-bbold'.

l.2 input b-bbold

                 ;

Please type another input file name

! Emergency stop.

l.2 input b-bbold

                 ;

Transcript written on bbold25.log.

miktex-maketfm.exe: Windows API error 2: The system cannot find the file specified.

miktex-maketfm.exe: Data: bbold25.tfm

 5.
! Font U/bbold/m/n/24.88=bbold25 at 24.88pt not loadable: Metric (TFM) file not
found.
<to be read again> 
                   relax 
l.2280 \chapter{The $beta$}

? 

I've tried to debug and found that there is no problem with my setup (packages, etc.) because I can use equation in titles when I've deleted all my previous chapters. Subsequently, I tried deleting each chapter one at the time to determine what chapter causes the problem and, weirdly, it turns out that all the chapters are not compatible with my section. So in other words, I can put equations in titles if I start a new document, but for some reason it doesn't work with my existing dissertation.

I would also like to mention that the error printed above is mentioning MiKTex, which I have installed on my computer, but I'm using TeXworks because I like it more. This may have something to do with the problem? If anybody could help me with this problem then that would be great.

Best regards,

Edit to show the code that is not working:

\documentclass[10pt,twoside]{book}


\begin{document}

\chapter{Blabla}

\begin{equation}
e^{i 2 \pi \mathcal{N}}=\mathbb{1} \Rightarrow \mathcal{N}=n' \;,\; n' \in \mathbb{Z}
\end{equation}

\section{The $\beta$}


\end{document}

At the moment that I would delete the equation above, then it does work.

Also, this code does work:

\begin{document}

\chapter{Blabla}

\begin{equation}
e^{i 2 \pi \mathcal{N}}= \Rightarrow \mathcal{N}=n' \;,\; n' \in 
\end{equation}

\section{The $\beta$}

\end{document}

So it seems to be related to the \mathbb syntex.

share|improve this question

closed as off-topic by egreg, Werner, Peter Jansson, Qrrbrbirlbel, Martin Schröder Dec 7 '13 at 23:18

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

    
The first error is the relevant one here, and this is ! I can't find file b-bbold'. Is seems that you are \inputing a file not installed in your system. –  Gonzalo Medina Jul 14 '13 at 0:04
1  
Your code is missing the amssymb package (for \mathbb). Load it: \usepackage{amssymb}. Does the error persist? –  Gonzalo Medina Jul 14 '13 at 0:30
1  
@Hunter: You have forgotten to load package bbold: \usepackage{bbold}. And MiKTeX package bbold-type1 should be installed to avoid bitmap fonts. –  Heiko Oberdiek Jul 14 '13 at 0:56
1  
@Hunter: That's a different package, \mathbbm is provided by package bbm. And in TeX Live I get a bitmap font (bbm10.600pk). Vector fonts (Type 1, ...) are preferred for PDF. –  Heiko Oberdiek Jul 14 '13 at 5:02
4  
This question appears to be off-topic because the examples shown don't possibly match the error message. –  egreg Dec 7 '13 at 21:37