Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm trying to compile with LuaLaTeX for my first time but don't get results. The goal is to get microtype to work with the standard font for scrreprt (Latin Modern I think). Or maybe to check out Libertine for my future works.

When compiling with LuaLaTeX on a Windows XP machine with MiKTeX 2.9 installed and fully updated, I get several errors which I can't understand or get rid of. The fonts for Libertine are installed manually. Computer or Latin Modern should work ootb as I used them before with XeLaTeX.

What is happening here?

The errors are:

lualatex> ! LuaTeX error cannot read stdin: Bad file descriptor.

lualatex> ! fontspec error: "font-not-found"

lualatex> ! luaotfload | cache : Could not write lookup cache
lualatex> ! luaotfload | cache : Could not write to cache

I thought, that LuaLaTeX is looking for fonts on the internet and not in my c:/windows/fonts folder. Is that wrong? Or still missing? Or how do I enable that?

share|improve this question
2  
No, LuaLaTeX is not looking for fonts on the internet. Instead it looks in its internal database that is created in MikTeX by the tool mkluatexfontdb (which should have run automatically at some point). The tool searches in the local TeX folders and also in your Windows font folder. –  Alexander Jul 16 '13 at 13:07
3  
There are some problems with luaotfload (the package used to load fonts) in miktex currently. They should be solved with the next luaotfload update. In the meantime you can also download this file: github.com/lualatex/luaotfload/releases/download/v2.3a/…, unzip it somewhere and add the root folder as a new root in miktex settings. –  Ulrike Fischer Jul 16 '13 at 13:08
    
That works. Put it to the MiKTeX-Folder and will delete it when the update comes out. –  LaRiFaRi Jul 16 '13 at 15:39
add comment

1 Answer

up vote 1 down vote accepted

This problem has been resolved by the last update. Thanks to Ulrike Fischer for the work around and to Christian Schenk for the updated MiKTeX files.

To get it running, just go to MiKTeX 2.9 - Maintenance (Admin) - Update (Admin) and get at least the new luaotfload package.

If Ulrike Fischers workaround has been implemented, this folder can be removed as well as the root path in the MiKTeX settings.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.