Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Prior to today, TeXLive 2013 updated fine through the manager on Ubuntu 13.04, but now it seems to be stuck in a loop. I have done this three times now.

enter image description here

So I have followed this processes by hitting ok, selecting update all installed, and then re-starting tlmgr, but it keeps taking me through scenario over and over again.

After I hit ok, I receive this message

enter image description here

What can I do to get passed this problem?


So I determined this only occurs when texlive.infra needs to be updated. When it is just packages, the GUI works fine.

share|improve this question

1 Answer 1

up vote 3 down vote accepted

So I have found a way to resolve the issue:

If I update from the command line, everything works out fine. However, the gui worked previously. What I had to do is:

  1. sudo /opt/texbin/tlmgr update --self

  2. sudo /opt/texbin/tlmgr update --all

However, I would like to find out why the gui stopped working, and I had to resort to the command line for the updates when this wasn't the case a few weeks ago.

As I posted in the updated question, I only need to use this procedure when texlive.infra needs to be updated.

share|improve this answer
    
There was 9aug tlmgr bugxfix release. In any case command line tlmgr update --self --all # update infrastructure and all packages is recommended sometimes texlive.infra updates may not work on GUI as it's updating itself(I suppose). –  texenthusiast Aug 12 '13 at 2:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.