Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I was trying to install TeX Live (on Ubuntu10.04) following the instructions contended in http://tug.org/texlive/quickinstall.html (c.f. thread Typesetting a document using Arabic script).

I've chosen scheme -> customised mostly to uncheck support for languages I will never need as well as music typesetting and advanced maths. Beside that I've left default.

After installation I wanted to run tlmgr -gui to install LaTeX and pdfLaTeX but it didn't work: command not found. I've checked .log installing file (/usr/local/texlive/2010/install-tl.log). I won't post it here entirely (unless somebody asks) - it's pretty long, but here is what I've found in it searching for error:

TLDownload::get_file: response error:
  404 File 'dprogress.tar.xz' not found

TLDownload::get_file: response error:
  404 File 'draftcopy.doc.tar.xz' not found

TLDownload::get_file: response error:
  404 File 'natbib.doc.tar.xz' not found

TLDownload::get_file: response error:
  404 File 'placeins.doc.tar.xz' not found

TLDownload::get_file: response error:
  404 File 'polski.tar.xz' not found

TLDownload::get_file: response error:
  404 File 'placeins.doc.tar.xz' not found

TLDownload::get_file: response error:
  404 File 'polski.tar.xz' not found

TLDownload::get_file: response error:
  404 File 'preprint.tar.xz' not found

TLDownload::get_file: response error:
  404 File 'txfontsb.source.tar.xz' not found

TLDownload::get_file: response error:
  404 File 'xnewcommand.tar.xz' not found

TLDownload::get_file: response error:
  404 File 'active-conf.doc.tar.xz' not found

I have no idea where the problem may lay. I would be very greateful for any tips. If there is any further information I should provide, please ask.

P.S.

The default paths are:

<D> directories:
   TEXDIR (the main TeX directory):
     /usr/local/texlive/2010
   TEXMFLOCAL (directory for site-wide local files):
     /usr/local/texlive/texmf-local
   TEXMFSYSVAR (directory for variable and automatically generated data):
     /usr/local/texlive/2010/texmf-var
   TEXMFSYSCONFIG (directory for local config):
     /usr/local/texlive/2010/texmf-config
   TEXMFVAR (personal directory for variable and automatically generated data):
     ~/.texlive2010/texmf-var
   TEXMFCONFIG (personal directory for local config):
     ~/.texlive2010/texmf-config
   TEXMFHOME (directory for user-specific files):
     ~/texmf

I haven't change here anything.

UPDATE

It took me some time, but I've proceeded the installation once again. This time, no errors, but still nothing works.

I've run installation, than I've added to /etc/profile paths (PATH=/usr/local/texlive/2010/bin/i386-linux:$PATH; export PATH). When I try to check tex --version I get the message that:

'The program 'tex' is currently not installed. You can install it by typing: sudo apt-get install texlive-binaries.

I have no idea, what could I have done wrong but there should be something...

share|improve this question
    
Looks like the installer couldn't find a lot (all?) of the installation files. Are you behind a firewall or router like in a campus network? Try the installation again and make sure to select a HTTP server, not a FTP server as a source. –  Martin Scharrer Mar 1 '11 at 23:13
    
Thanks to all. @Martin: I've removed previous installation. I'm proceding once again, but have no idea where I should select server as a source. I'm using wireless connection at my private home. @Jasper: I thought so, but when I wanted to run LaTeX the output was that it's not installed... Default settings of directories are listed in the body of question. –  maria Mar 2 '11 at 0:03
    
@Jasper: For sudo - yes, I did. For the paths I have omitted, but what are the errors in the .log file? The log was created during the installing process (at least I think so). Thanks for warning! :) –  maria Mar 2 '11 at 0:24
    
@Jasper: I've entered sudo ./install.tl. In opened installer I was only entering commands to move it it (and I to confirme settings). Should I have typed sudo I? Or each time I type anything? BTW it wasn't gui but textual, if it changes anything. –  maria Mar 2 '11 at 0:46
    
@Jasper: for the moment second installation is running. First one was with gui and as now I have used sudo only to call the installer. I can always remove second installing if it doesn't work :) –  maria Mar 2 '11 at 0:58
show 3 more comments

2 Answers

up vote 5 down vote accepted

Two thinks I would check:

  1. did you adjust your $PATH to include the texlive bin directory? If you did not, your shell will not be able to find your binaries, and trying to run any of them will result in a command not found error.

    Note that if you runt tlmgr as root (using sudo) as you should (otherwise it will not be able to write to your texlive directories and therefore will not be able to update anything), you may need to change the root's path, too.

  2. the 404 errors are worrisome. It does look like the CTAN mirror that gets automatically chosen for your location is having problems. You could try to use a different mirror. Find another nearby mirror here and then use the -repository option with the chosen mirror's url when using install-tl. For more information look here, and read the section on -repository option.

share|improve this answer
    
It seems I need to read a lot to learn how to do it, so it will take mi some time. I'll post after. Thanks a lot. –  maria Mar 2 '11 at 11:46
    
I was trying soon after to proceed installation once again using different mirrors, without succes. I gave up for a long time, now I tried once again and everything was fine. –  maria Nov 17 '12 at 12:55
add comment

try another mirror or a CTAN node:

tlmgr --self --all --repository http://mirror.ctan.org/systems/texlive/tlnet update

if it doesn't help, then try:

tlmgr --self --all --repository http://www.tex.ac.uk/tex-archive/systems/texlive/tlnet update

share|improve this answer
    
Thanks a lot. Now I'll have to read a lot in order to understand exactly what should I do, I'll post later what would be the result. –  maria Mar 2 '11 at 11:49
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.