Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm trying to format a document following my organization's style guide. I'm using XeLaTeX for the font flexibility. I made a minimal document

\documentclass{article}    
\usepackage{xltxtra} %% For XeTeX font commands
\setmainfont[Ligatures=TeX]{Frutiger LT Std 45 Light}
\usepackage[includeheadfoot, margin = 0.5in]{geometry}

\begin{document}
Main font, no styling, \emph{with emphasis}, \textbf{and bolded}.
\end{document}

and the \emph{} and \textbf{} text comes out just fine, but the rest is garbled:

garbled

The part where it's probably my fault

I needed to use this font in some graphs generated in R. I have several fonts in the Frutiger family installed on my (Windows) machine, and they're OTF fonts. To get the font to work in R, I need to use the extrafont package, which only works with TTF fonts. So I fed Frutiger LT Std 45 Light into an online OTF to TTF converter, and reinstalled the TTF version. It works great for my R figures, but maybe that has something to do with my XeTeX font problems. If I run the above example with \setmainfont{Frutiger LT Std 55 Roman} instead of using the TTF-converted light face, nothing is garbled, it's just too heavy.

My compilation report for the example above says 0 Errors, 0 Warnings; the .log file reports

.................................................
. fontspec info: "defining-font"
. 
. Font family 'FrutigerLTStd45Light(0)' created for font 'Frutiger LT Std 45
. Light' with options [].
. 
. This font family consists of the following shapes:
. 
. * 'normal' with NFSS spec.:
. <->"Frutiger LT Std 45 Light/ICU:script=latn;language=DFLT;"
. 
. * 'bold' with NFSS spec.:
. <->"Frutiger LT Std 45 Light/B/ICU:script=latn;language=DFLT;"
. 
. * 'italic' with NFSS spec.:
. <->"Frutiger LT Std 45 Light/I/ICU:script=latn;language=DFLT;"
. 
. * 'bold italic' with NFSS spec.:
. <->"Frutiger LT Std 45 Light/BI/ICU:script=latn;language=DFLT;"
.................................................

Any help/pointers?

share|improve this question
2  
If you are using XeTeX < 0.9998 on Linux or Windows, make sure you don’t have several different copies of the font installed, as this is known to cause issues like that. –  Khaled Hosny Jul 19 '13 at 20:21
    
@KhaledHosny That was the issue. I updated XeTeX and now everything is working. If you'll post as an answer I'll accept. Thanks! –  shujaa Jul 19 '13 at 21:08
    
This is a duplicate of tex.stackexchange.com/q/56739/729, so I think we should just mark it as such. –  Khaled Hosny Jul 20 '13 at 9:04
    
Which is a duplicate of tex.stackexchange.com/q/35090/729 :) –  Khaled Hosny Jul 20 '13 at 9:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.