Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am using TexStudio as an editor and everything works great so far. But since I entered the "typing" phase of my document production, I realized that it has some problem with some french accents input. When I am typing , if I type the "^" sign and then the "e", it will, most of the time, only enter "e" and not "ê". If I "insist", meaning that if I delete it and enter it a second time, it will mostly work and type "ê".

The input language is set to french and I don't have any problem rendering the letters with XeLaTeX. I tried with 2 different keyboards and on different softwares and it is not a hardware issue.

My question is then: Is there a way to make TexStudio recognize and input the accented letters on the first attempt?

\documentclass[11pt,twoside,titlepage]{article}
\usepackage[francais]{babel}
\usepackage{fontspec}
\defaultfontfeatures{Ligatures=TeX}
\usepackage{lipsum}
\begin{document}
\lipsum
\end{document}

I compile using XeLaTeX, so entering "ê" or any special character is no problem at all (and much faster when you are writing a non-english text...) In fact, my issue is precisely to be able to keep using french letters without having to use the basic latex encoding.

Is there any encoding specification missing in the preamble? Since the building of the output worked flawlessly, I thought it would be irrelevant to my keyboard input problem.

EDIT: Just to make clear, the problem is NOT related to the absence of the accents in the built PDF file. The problem is related to the action of typing on the keyboard and having texstudio not entering the accented letters, as if it would be "protecting" the code against wrong characters.

share|improve this question
    
Could you please add a mwe ? Since we don't know the encoding you use and all that things, we cannot really understand what happens. Anyway, I guess you're running windows.I guess you should try to input your accents as \^e –  Vser Jul 22 '13 at 14:53
    
Since I didn't see it as a properly TeX compilation problem, I didn't see the utility to add a mwe. The problem is before any compilation attempt is made, but if it might be useful, then I will add them. –  LeVulgarisateur Jul 22 '13 at 15:09
    
I am indeed running TexStudio on Windows 7, I'm sorry I forgot to mention. –  LeVulgarisateur Jul 22 '13 at 15:26
    
If you have the problem only with TeXStudio and not e.g. with word or some other win7 application I would say it sounds like a texstudio bug and you should report it there. But I couldn't reproduce the problem with my version of TeXStudio (not the newest) and a french keyboard layout on win7 "ü" (beside p) + e always gave ê. –  Ulrike Fischer Jul 22 '13 at 16:03
    
Did you try to change the encoding on the Options menu. You can set TeXstudio to recognize the encoding of the file when it opens it. What encoding are you using? ISO or UTF-8? –  Sigur Jul 22 '13 at 16:05

1 Answer 1

Try to change the encoding correctly. See the image below: enter image description here

share|improve this answer
    
I will try that! I must say that it also bugs me, because sometimes it works, but mostly I have to erase and type again. I will make sure once again that it's not a hardware problem, although I had the feeling it was the same with my two keyboards. I was using the UTF-8 encoding –  LeVulgarisateur Jul 22 '13 at 17:49
    
It seems that with XeLaTeX I won't have a choice but to use UTF-8. Now the accents don't appear properly. –  LeVulgarisateur Jul 22 '13 at 17:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.