Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I used to be able to right click on the pdf and the bottom of the list would be a "jump to source" option which would take me to the source code where I had clicked on the pdf. It is no longer there how do I get it back?

I am using Miktex 2.9 and texworks. Sorry I can't be more informative I am not very computer literate.

share|improve this question
1  
Do you have any non ascii chars in the folder path to your PDF? Such as c:/Users/André/Documents, at least earlier TW versions might have problems with this regarding synctex. When you compile does it shortly mention synctex at the bottom left of the PDF viewer? If it does not then synctex is broken for some reason –  daleif Jul 25 '13 at 14:33
    
The same problem may occur if your *.tex file has spaces in its name. This holds true for my MikTex 2.9 running under Win7. The *.synctex.gz file simply is not created. Unexpectedly, there is no explicit error message addressing this problem during compilation. –  user47668 Mar 10 at 9:18
    
It can also happen if you have non-ascii letters in the folder name leading up to the file or in the filename itself. –  daleif Mar 10 at 9:52
    
@daleif, would You care to add Your comment as an answer, so I can upvote You? Your suggestion saved the day for me :) –  Rauni Sep 23 at 10:16
    
@Rauni, answer added. –  daleif Sep 23 at 10:20

2 Answers 2

This functionality is provided by synctex - without more information it's not possible to say why it's gone.

Also Ctrl+left click would be the hotkey for this feature.

I have "$synctexoption" as a compiling parameter from pdfLaTeX - look if that one is set in texworks.

share|improve this answer
    
Ctrl+ left click doesn't work either does this help? –  Henry Duncanson Sep 6 '13 at 8:54

Synctex is a bit frizzy about file names and paths. On some systems it may not like non ascii letters in file names or paths. In order to test, create a folder called, say, latex-test in the root, i.e. c:, copy your file there and see if synctex works.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.