Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I need to build the .sty of different packages to be loaded in my input file (I have to do things manually). I am working on Windows and get a very strange behaviour: latex.exe seems to be missing the file I want to build even if I run latex.exe in the directory containing the .ins file. What's going on?

EDIT: I am using Miktex

C:\Travail\Tools\localtexmf\tex\latex\tocloft>ls
README  texput.log  tocloft.dtx  tocloft.ins  tocloft.pdf  tocloft.sty

C:\Travail\Tools\localtexmf\tex\latex\tocloft>latex.exe tocloft.ins
This is pdfTeX, Version 3.1415926-2.4-1.40.13 (MiKTeX 2.9)
entering extended mode
! I can't find file `tocloft.ins'.
<*> tocloft.ins

It looks like it is more or less randomely working, sometimes I can build, sometimes not...

share|improve this question
    
NICE I get it now ! It is a valid answer I think... feel free to write it as such –  statquant Jul 30 '13 at 10:53
    
Glad my comment was on target! I've written it up as a full answer per your suggestion. –  Mico Jul 30 '13 at 12:50

1 Answer 1

up vote 1 down vote accepted

One of MikTeX's (more or less well known) "features" is that it doesn't automatically find newly installed files -- in your case, tocloft.dtx and tocloft.ins -- in the current working directory if that directory happens to be in the search path of the TeX distribution, whether in the main directory tree or in the "localtexmf" directory tree.

One must update the filename database to get MikTeX to "find" such files. Clicking on the "Update FNDB" button in the MikTeX Settings utility will fix the problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.