Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Okay, so everything was fine previously. But when I re-installed my machine and thereby also MiKTeX and my beloved TeXstudio my old documents complain on:

\usepackage{inconsolata}

No worries, it's not gone, just seems replaced:

\usepackage{zi4}

Although now I get the following errors:

Trying to make PK font ot1-zi4r-0 at 600 DPI...

Running miktex-makemf.exe... miktex-makemf: The ot1-zi4r- source file could not be found.
Running ttf2pk.exe...

miktex-makepk: PK font ot1-zi4r-0 could not be created.

Tried all the initexmf tricks etc, nothing works... But then I've been looking around in the CTAN archive and found the following trick in the documentation file:

\pdfmapfile{+zi4.map}
\usepackage{zi4}

Can anybody explain to me:

  • Why doesn't the font work out-of-the-box?
  • Why and how does the \pdfmapfile trick work?

Thanks.

share|improve this question
    
Did you run updmap (or initexmf --mkmaps which is the same) in a command line as user(!) ? –  Ulrike Fischer Aug 1 '13 at 8:50

1 Answer 1

I guess you installed MiKTeX as basic version? The basic version has not all packages included you need.

In the MikTeX package manager you will find a package inconsolata including all you need.

In the readme of this package you can read:

Copy the Inconsolata-zi4.tds.zip to the root of the folder you use for personal additions to the TeX trees, open a command window, chdir to that folder, and type

unzip Inconsolata-zi4.tds

This all should be done with the package manger. For me I could use the font directly after instalation with the package manager, but perhaps there was an error on your system. So proceed as told in the readme:

initexmf --update-fndb initexmf --edit-config-file updmap

The latter command should open updmap.cfg in your default editor, commonly Notepad. Add the line

Map zi4.map

to updmap.cfg, save and close. Then, in the command window, type

initexmf --mkmaps

You can ignore error messages that may occur here. This should result in a properly enabled garamondx.

The "\pdfmapfile trick work" is just a workaround for the proper installation of the font. You should complete the font installtion.

This is a longer version of the comment @UlrikeFischer wrote.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.